Preventing monitor energy savings mode through fullscreen multimedia applications


when watching fullscreen VLC videos, either streams or videos from the local storage, whenever I do not use the mouse/keyboard, after a few minutes both screens go dark. I checked the energy savings settings, and lo and behold, it is set to disable the monitors after 10 minutes of inactivity.

That would be fine, but I am sure that my previous distribution also running KDE Plasma current had the same or similar energy savings settings, however, it did not happen during fullscreen video.

Looking through the energy savings settings of KDE I do not see any option that would translate to a prevention of this behaviour when watching fullscreen video, but I bet there is such a setting - just maybe not exactly there.

Could that be a hidden setting, only reachable via KDE config file? Or a VLC setting? Or maybe it’s an external tool that Manjaro had installed by default?



Thank you for the tip, it looked very promising, however that option in VLC is already active.

I just realized something unusual. As it seemed as if the VLC setting didn’t work for me, I thought I could set the delay for the monitor disabling to anything higher. I set it to 45 minutes, thinking that I would probably not see the problem again.

However, 10 minutes into a VLC video (or rather, I guess it’s 10 minutes, I never timed it) the screens went blank. It would seem that whatever happens to my monitors isn’t the energy saving 10 minute delay from the energy savings settings of KDE Plasma.

I have no idea what it could be otherwise.