PPM Error on Boot while HDD is mounted

Hello everyone,
this is my first post here and my first time using Linux so bear with me :slight_smile:

My specs:

Operating System: EndeavourOS 
KDE Plasma Version: 5.27.6
KDE Frameworks Version: 5.107.0
Qt Version: 5.15.10
Kernel Version: 6.3.9-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 7800X3D 8-Core Processor
Memory: 30.5 GiB of RAM
Graphics Processor: AMD Radeon RX 7900 XT
Manufacturer: Micro-Star International Co., Ltd.
Product Name: MS-7D78
System Version: 1.0

I installed Endeavour Os on a 1TB SSD and wanted to mount a second 2TB SSD for steam games and a 4TB HDD as a data dump and that worked (kind of).
Here is my fstab for the two mounts:

#hdd
UUID=780339c6-2e8e-46ab-9f4c-e689109e73a7 /media/hdd     ext4    defaults 0 2
#ssd
UUID=c51bdd36-3995-481e-b623-0e0a7a8c294c /media/ssd     ext4    defaults 0 2

I added rwx for user, group and other on both /ssd and /hdd via chmod in order for steam to access both.
I also used sudo chown -R <your user name>: <your user group> /mnt/<folder name you created> from the tutorial to take ownership of the folders.

Now where is my problem:
On boot I get a ucsi_ccg PPM init failed (-110) error with the UUID of the hdd 780339c6-2e8e-46ab-9f4c-e689109e73a7, then I have to wait for about a minute while the error is resolved I guess?.
Then I can use the system like normal. This error is displayed ~60% of the time on boot.
The other 40% the system boots normally and I get to the login screen right away, however I can’t use any usb devices for about the same time the PPM Error needs to resolve.

My guess it, that the PPM Error gets thrown on every boot, but is hidden 40% of the time while I’m stuck on the login screen.

The USB devices meanwhile work in the BIOS and get power at all times during boot.

These are the Error lines from journalctl:

pc kernel: ucsi_ccg 0-0008: failed to reset PPM!
pc kernel: ucsi_ccg 0-0008: PPM init failed (-110)

And on boot the following text is displayed:

ucsi_ccg 0-0008: failed to reset PPM!
ucsi_ccg 0-0008: PPM init failed (-110)
[***  ] A start job is running for /dev/disk/by-uuid/780339c6-2e8e-46ab-9f4c-e689109e73a7 (5s / 1min 30s)
[**   ] A start job is running for /dev/disk/by-uuid/780339c6-2e8e-46ab-9f4c-e689109e73a7 (11s / 1min 30s)

My question now is, how to fix the PPM Error?

Have you checked to see if there is a newer UEFI Bios update for the laptop?

Edit: I think this error message is for usb-c ports on nvidia gpu
Should be harmless but could be blacklisted in order to not have the message. :thinking:

https://github.com/torvalds/linux/blob/master/drivers/usb/typec/ucsi/ucsi_ccg.c

Hello, I updated the Bios yesterday with the newest version.
And my ADM Card also has a usb-c port so maybe that is at fault.

But how do I blacklist such a error message, do I have to compile the c file you send on my own and change the code so that the part regarding the port is no longer triggered?

And does it have something to do with the start job for the hdd or is this something completely unrelated and a issue by itself because I don’t want to wait a minute on each boot for this job to finish :confused:

1 Like

I’m not sure about the start job? I don’t think so but not 100%. It would seem to me it’s just an informational error message related to usb-c.

Edit: The only information i see is that it is related to nvidia usb-c?

You could try blacklisting it by creating

/etc/modprobe.d/blacklist-nvidia-usb.conf

add

blacklist ucsi_ccg

Then reboot and see if the error still shows.

Ok thanks for the reply, I will do more research in how to blacklist the error and what I can do the make the start job faster.
If I find a solution, I will update this post.

I realize you don’t have any nvidia gpu but as i say i think it’s just an error message. Normally you can just ignore it. Not sure what the issue is with the start up. :thinking:

Probably have to see more logs and someone else with more knowledge on the boot process maybe could give a better answer or point in the right direction. I’m just not sure at the moment.

Edit: It won’t hurt to try the blacklisting. If it causes any issue just remove it.

Ok after some additional research and your responses I come to the conclusion, that the issue I have consists of 3 separate errors:

  1. ucsi_ccg 0-0008: failed to reset PPM! which I don’t really care about, because it doesn’t slow down my pc and because I’m not using the port
  2. The start job that slows the boot process down, which I have resolved by re-partitioning and formatting the drive
  3. A newly discovered error:
Linux device descriptor read/64, error -110
usb 3-7: device not accepting address 9, error -71
usb 3-7: device not accepting address 10, error -71

I did more research with lsusb -tv and saw that bus 3 port 7 has no attached device.

I found the following post which sound exactly like my error but because of the reddit blackout I can’t see it: https://www.reddit.com/r/kde/comments/tg513o/kde_login_screen_unresponsive_for_about_a_minute/

These two post also align with my error and where also related to one another while being resolved:
https://bbs.archlinux.org/viewtopic.php?id=282613
https://bbs.archlinux.org/viewtopic.php?id=282614
The solution was to add amd_iommu=off as a kernel command line parameter for the bootloader.
I use systemd as my bootloader and have no idea how to set it.
I found /efi/loader/loader.conf, do I have to add the option like this amd_iommu off or like this options amd_iommu=off?

And is this even the right file for this?

My current loader.conf looks like this:

default 77a585cdb97440bcaf270073c0550667*
timeout 5
console-mode auto
reboot-for-bitlocker 1

It would be amd_iommu=off and you would add it to /etc/kernel/cmdline and then run sudo reinstall-kernels

You could try this and see if it works. If not you can remove that entry and run the command again to reinstall kernels.

Edit: Essentially if you add that kernel parameter then this is what it does.

off - do not initialize any AMD IOMMU found in the system

Alright, I will try that once I can log again into my system :slight_smile:
Because as stated in KDE Plasma unresponsive Login screen and freeze after one minute I can no longer login to my system…

Just wondering if you had tried blacklisting the module for the error from my previous post?

I didn’t blacklist it the start job, I solved it by by re-partitioning and formatting the drive.
And I just ignored the usci_ccg Error

Okay so that was related to the start up? What did you do with the partitioning.

Edit: Now why is it not booting to the desktop?

I used parted to re partition it and mkfs.ext4 /dev/... to format it.
And I have no idea why I can’t login anymore, the login screen just freezes.

Okay I’m not following. Did you reinstall?

Edit: Or is this the external drive?

I have one 1TB SDD on which I installed the Os.
And I got two other drives, one 2TB SSD and a 4TB HDD.

The 4TB HDD was the cause of the start job as explained in my very first post.
To solve this I re-partitioning and formatted the HDD NOT my boot SSD.

All drives are internal and I setup fstab so that all 3 are mounted on boot. The 4TB Hdd and 2TB ssd are listed in my first post.

So you might as well close this then if the usb error is a non issue. I see you have opened another topic because the issue now is not being able to log in.