Power-profile cannot change to power saver at using wm

Hi, i’ve been try eos with i3wm and got this bug(?), so i switch to eos no desktop installation and then installing hyprland, and got this bug too.
im switch profile using cli:

powerprofilesctl set power-saver

for the first sec i check with running powerprofilesctl the current profile is set to power-saver, but after a sec i check again, that change to balanced profile again.

Thanks

  1. Please provide hardware information.
  2. Please check if you are using any other conflicting power management daemons on your system. E.g: tlp, thermald, etc.
  3. Check the journal logs after you run the powerprofilesctl set power-saver command. (Hint: journalctl -b 0). It could be a firmware or kernel issue. If it is, the journal entries might contain clues.
  4. Go through your BIOS settings and see if there are any energy-management settings. If you set ‘Balanced’ in your BIOS, the BIOS might be overriding the operating system’s setting.