Power LED blinking continuesly after hard shuntdown

Hello Everyone,

I have some weird issue, where the power led is continuously flashing 0,5 second on 0,5 second off. Everything works fine it’s just very annoying.

First a quick background; Im using EndavourOS for almost 3 years now as my main OS, with a windows dual boot (installed on separate drives). Which has been working very well, anyways I had to upgrade the SSD to a bigger one and just reinstalled EOS on the new drive and also switched from grub to systemd. It works, no problems at all.

The problem I have now is the power led is continuously flashing and it has to do something with this endavouros install. Let me explain why I think it is is caused by this install and hopefully someone is able to point me in the right direction.

  • When did this start happening? I worked fine for 2 weeks on this fresh install, but the flashing started immediately after I had to cut the power because of a lockup. I was messing around with virtualbox at that time, it locked up and was completely controllable.
  • On my old installation I have cut the power before and after booting is was fine, so i don’t know why it is different now. and besides the flashing power led, everything is fine.
  • The flashing starts from the end of the boot sequence till the halfway of the shutdown sequence of eos. When I leave it on the bios, systemd menu, windows or live environment it does not do this.
  • It does not happen in Windows, the Endavour live environment and also not on this install before I had to do the hard shutdown. So, it has to be something caused by the hard shutdown.
  • It is not a hardware or wiring issue, because it did not change and because it is limited to only this install of eos after the hard shutdown.

This problem is, when I start googling this, people are pointing to a hardware failure and even mention the led is not controlled by the OS. But his cant possibly be the case, because it is only limited to this installation after I did a hard shutdown. If something did really fail it should also do this when booting windows or a live environment and it does not.

For additional information; most recent version of eos, kde and up to date. I did not really install anything yet, besides Virtualbox and Discord.
The motherboard is a MSI Z170 MATE. The debug leds on the motherboard are off and the power button led is wired to the Power led and HHD led. These work as expected in eos and widows so they are correctly wired.

Tbh I have absolutely no idea where to look for this and i also don’t want to pull the wire, because then i would not have the HHD LED indication anymore in windows, where it does work.

Edit: I tried to reproduce it by reinstalling eos, use it a bit and just pull the plug. I did it twice, first time everything was fine, second time the same issue with the blinking power led.

Edit: Reinstalled fresh again and using it like normal the whole day and its fine. So, I’m still convinced it is not hardware related.

This statement isn’t true. Just because you cut the power before and had no issue doesn’t mean the next time you won’t.

Don’t be surprised when one day you have a permanent hardware failure where either the power supply is toast or the motherboard. This can and does happen.

If it’s working fine now i wouldn’t be trying to figure out why it happened. It’s obvious the power was cut midstream and the system isn’t shutdown properly. This is hard on the hardware and the file sysytem. Sometimes it’s unavoidable but not something to continue to do.

Do you have the latest Bios which is version 7971vAG dated 2018-06-26?

Edit: You could also have the hard drive fail at some point.

It feels like the hard shutdown made the bios/uefi “think” your pc is hybernation mode hence the blinking light

I did mean this in the way of, lets say something did fail and would trigger some sort of hardware error. eg the psu failed and the 12v became unstable and triggers a error, this error should also be there independent of the os used. So, when I switch os, I should always get this error.

Anyways if I have a hardware failure, then I/we identify what did fail and buy a the new component, but I don’t think this is applicable on this situation. I do agree there is a bigger chance having some failure and/or data corruption on storage devices when suddenly cutting power.

I think it was caused by running out of ram and it completely locked up. I always leave it for some time in case you get some control back to shut it down, but if not there isn’t much else you can do decides to cut power.
I think I’m on the latest bios version, I known i have updated it at some point, but i could check.

Not a weird thought, but then it would come from the motherboard getting some information deciding to be in sleep or hibernation. But then would assume this would also have a influence on power states and performance.
I don’t really use hibernation or sleep modes anyways, but the blinking is faster the it would when windows is in sleep modus.

this is weird, power led should never be connected to harddisk led header and both is even weirder though

fast startup is disabled in bios? this can lead to this kind of issues too