Power Devil Restart Loop bug after updating today

On further investigation, it appears that I have to use the

killall org_kde_powerdevil

and then run

kstart5 /usr/lib/org_kde_powerdevil

and let the konsole run. The problem is that org_kde_powerdevil at startup does run. The journal ctl error reads

Oct 30 10:51:46 attish-archLinux org_kde_powerdevil[3705]: org.kde.powerdevil: org.kde.powerdevil.chargethresholdhelper.getthreshold failed “Charge thresholds are not supported by the kernel for this hardware”
Oct 30 10:51:46 attish-archLinux org_kde_powerdevil[3705]: org.kde.powerdevil: org.kde.powerdevil.backlighthelper.brightness failed
Oct 30 10:51:51 attish-archLinux systemd[901]: plasma-powerdevil.service: start operation timed out. Terminating.
Oct 30 10:51:51 attish-archLinux systemd[901]: plasma-powerdevil.service: Failed with result ‘timeout’.
Oct 30 10:51:51 attish-archLinux systemd[901]: plasma-powerdevil.service: Consumed 1.745s CPU time.
Oct 30 10:51:51 attish-archLinux systemd[901]: plasma-powerdevil.service: Scheduled restart job, restart counter is at 46.
Oct 30 10:51:51 attish-archLinux org_kde_powerdevil[3731]: org.kde.powerdevil: org.kde.powerdevil.chargethresholdhelper.getthreshold failed “Charge thresholds are not supported by the kernel for this hardware”

This is a problem. So it keeps on restarting and never finishes. I have to kill the process and restart it like this. Is this a problem on my end? I never had this problem before. It was only when I updated the computer yesterday that I noticed severe hitching which has caused me to panic. I hope this helps people that are also looking for this problem.

1 Like

Why would you need to change to another OS because of KDE update failures? Why not just uninstall kde and use another DE or a WM. Remember this is not Windows you can add and remove Desktops as you wish. Please stop thinking like a windows user and start thinking like a Linux user.

1 Like

try to downgrade powerdevil and see if it works

I do not know what a Windows users think like, so I can’t respond to that. Basically, people have advised me not to use Arch Linux based systems on a production machine, so I was thinking about switching to Mint (which I personally do not want), as I like KDE with EndeavorOS.

Is there a guide which can help me switch to a very stable DE, that I can use for my main production machine?

Downgrading does not work.

Not a DE user so not sure about a guide for removal but i’m sure there are plenty.

How long have you been using Linux?

Arch is perfectly fine on a production machine.

Since 2018.

I am thinking about switching to either Mint, EndeavorOS Openbox, or EndeavorOS XFCE.

Arch is 100% fine, it is the updates that people push that are not. I think OpenBox might be the best option as they probably don’t push updates that regularly break things.

There are no Openbox updates as the project has not seen active development in like ten years I think. So definitely no issues with updates. I use openbox myself and love it over any full fledged DE.

1 Like

Thank you. Openbox is also pre-configured, I believe, so I guess that it will work for me. It is sad to let KDE go. They have released quite a few updates that have caused problems recently, not just for me, but for many users.

I switched PowerDevil off right now, but I have no idea what effect it might be having on my computer.

You might want to have a look at the following articles to see if you can do your power management from the command line rather than from a graphical interface:


At the moment I have downgraded packages. Now pacman reads this when I run

sudo pacman -Syu

This is what it reads

warning: ddcutil: ignoring package upgrade (1.4.1-1 => 2.0.0-1)
warning: powerdevil: ignoring package upgrade (5.27.8-2 => 5.27.9-2)

This is to help people that may have this problem. This problem isn’t solved yet.

you need to edit the pacman config file and remove those two from the ignore list. you probably added them to it when you downgraded.

Thank you. I know about them. I just left them there so that people who are effected by this problem know which version they need to downgrade to, that’s all.

1 Like

KDE works OK here, so hard to tell what the problem is. Some logs might reveal the reason(s), e.g. the latest journal session, you can use eos-log-tool for providing that.

Anyway, if you think of changing to XFCE, here are some things to consider:

  1. Make sure you have successfully backed up your important (=personal) data to an external disk.
  2. Program eos-packagelist shows the packages for each DE. These lists can be used for removing the old DE and adding the new.

If you change the DE like this, you must carefully check each package you remove or add. And there can be conflicting packages which might not be shown on the lists, e.g. window managers. They must be taken care of as well.

So, it probably is much faster to simply reinstall (after backing up your data).

At the moment, I have downgraded the two packages that I listed above. I think the logs will not read anything because it is working fine for now.

The problem is, I think it only broke for me. I don’t know what I may have done that was wrong. There is definitely a restart loop. Do you want me to give you a video to you showing the restart loop after upgrading the packages again?

I have posted a video on YouTube. This has fixed the restart loop, but I will only mark it as a solution if the EndeavorOS team doesn’t think that it would break other things in the system.

Should have went to Odysee or Rumble. Youtube is anti user.

This was happening for me as well ever since updating yesterday. Caused consistent spikes on random cpu cores to ~75% usage on that core every couple of seconds. It would cause slight visual stutters in most programs when it happened. Running killall org_kde_powerdevil would fix it temporarily but it would return on reboot.

The fix in the video by @attishno1 worked perfectly for me. I didn’t notice it affecting startup times, but I didn’t really measure the difference.

The fix is changing these two variables in /etc/xdg/autostart/powerdevil.desktop


Change them to:


Looks like there is an open bug report here: https://bugs.kde.org/show_bug.cgi?id=476375

I am glad it worked. There is a minor delay, but it is hard to notice. I noticed it because I was using a custom Splash that had a loading bar on it. By the way, this problem can still occur even after the fix.

I once logged out and then back in, and it started again. I have since then switched to Cinnamon.

Oof, thanks for the heads up on it not always working, I’ll have to keep an eye on it and hope for a fix :crossed_fingers:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.