Post installation oddity

Just did a test install using the 08 iso (had it around and didn’t see the new one until later…). Installed in UEFI mode on an HP 8200 Elite (i5, 8 GiB RAM, 500 GiB disk). The machine already had a fresh Windows 10 install.

I used Gparted to add partitions (8 GiB swap, 30 GiB /, 200 GiB /home). I mounted the EFI partition as /boot/efi. Install was fine. When I rebooted, I got a Grub menu with EndevorOS and Windows. Started Endevor, worked fine. I then wanted to check that Windows would start, so I rebooted and selected the Windows option. That also worked.

The oddity comes on the next reboot - no Grub menu, just straight into Windows. I’ve found that by using F9 to get the HP boot menu, I can select EndevorOS, which then gives me the Grub menu. But I can’t get the Grub menu by default. I can’t see any option in the HP boot menu to change the boot order.

I’m a long term Arch user, but I’ve little or no experience with EFI booting. So, have I missed something in the install? The machine is quite old (don’t think it has a secure boot option at all), so maybe there is something odd in the EFI implementation. Any guidance would be very useful…

hello,what did you put flag on gparted

a little advice that I can give is when you make a new installation and if you have partitioning problems make screenshots, so we can help you, thank you

1 Like

Welcome @toothandnail I think if you go into your Uefi bios the boot order can be changed from there. It needs to be grub first not Windows. This is a common issue with UEFI. Try this first.

Also if you can boot into Endeavour you can also use efibootmgr and it will show you the list of the boot order. Then you can use efibootmgr to change the order so grub is first and windows is second and then the rest in the list.

List current boot entries
sudo efibootmgr

Example list (Windows is 0001 and Grub is 0009)
BootOrder: 0001,0009,000B,000C,0000

To change boot order
sudo efibootmgr -o 0009,0001,000B,000C,0000

:slight_smile: Sorry, my mistake. I have a screen shot, meant to add it to the first message but forgot. Lets see if I can add it now…

Thanks. There doesn’t seem to be any option in the settings menu - it shows EFI sources as Windows boot loader, USB devices, CD drive. No entry for Grub at all there.

:frowning: Maybe it is age related. This is the result I get from running efibootmgr:

 [paul@orion ~]$ sudo efibootmgr
  [sudo] password for paul: 
  BootCurrent: 0000
  No BootOrder is set; firmware will attempt recovery
  Boot0001* USB Floppy/CD

Doesn’t look at all the same. Again, nothing I can identify as an entry for Grub.

That’s strange. What if you try setting it to 0001.
sudo efibootmgr -o 0001,0000

Or does it mean 0001 is the usb floppy/CD? I don’t think so. It has to be the grub entry?

Good question. Its odd that it doesn’t show the CD or the USB hard drive entries, if that’s what the current ones mean.

Tried your suggestion, and got this:

[paul@orion ~]$ sudo efibootmgr -o 0001,0000
[sudo] password for paul: 
Invalid BootOrder order entry value0001,0000
                                          ^
efibootmgr: entry 0000 does not exist

There may be something very strange in the old HP firmware…

So it’s using 0001 because it has the * beside it. But yet your first post shows 0000? I’m wondering if you go into gparted and mark the efi partition with flag /boot/efi? Just go into gparted and select efi partition manage flags and mark /boot/efi.

@toothandnail Hopefully you can figure it out. With the way you have it installed it’s easy to reinstall without a problem. I find it strange that it would only list one boot entry when grub did come up the first time? I’m well versed with UEFI and it’s intricacies but my hardware is fairly new. I’m not sure how early adaptations of UEFI are when they first started implementing it and or what yours HP has? Some of the manufacturers have not many settings you can change and others do. Just check all the settings and make sure secure boot is off. Sometimes the settings are buried in another setting.

Hello,
sounds like a BIOS/firmware problem. I have a HP laptop (not the same model as you) and it needed some simple settings to work properly.
I had to modify the boot order, and to do that, I needed to enable an admin password in BIOS in order to be able to change the boot order.

So, could you check once again if there is a way to change the boot order. Especially, if you find the setting for it, see it the grub entry is in the list or not. If it is not, you may need to re-create the EFI boot stuff with the grub-install command.

Hopefully this gives some pointers. But this might not help at all, as all laptops are not equal.

@toothandnail Hope things haven’t messed up your setup as i know sometimes trying to fix an issue causes another. As @manuel is saying and myself included sometimes the settings aren’t in plain site and i do remember like he is saying that on some HP in order to change a certain setting or have access to it requires setting an admin password. Or the setting is buried in another setting and also like he say’s you may end up having to reinstall grub.

Sorry for the slow reply - had a customer with a problem…

The partition is already set as boot, esp. I’ve not had a chance to try anything else yet - I’ll have a look and change if I can later.

@ricklinux

I also found it strange that the grub menu came up the first time and not on any subsequent boot. As I said in my first message, I’ve had little to do with UEFI, so I’m not sure if I’ve done something wrong or whether it is just the old firmware. Looking at the way the efi partition is mounted gives me this:

paul@orion ~]$ ls -l /boot/efi/EFI
total 3
drwxr-xr-x 2 root root 1024 Oct  6 14:45 Boot
drwxr-xr-x 2 root root 1024 Oct 20 17:26 EndeavourOS
drwxr-xr-x 4 root root 1024 Oct  6 14:40 Microsoft

When I look at the boot order options in the firmware, the only EFI entry that is on the hard drive is the Windows boot loader.

:slight_smile: I checked BIOS updates, found that I’m using a version released in 2011. There are updates that were released in 2014, so I’ll install the latest. Only problem is it will take a little while - HP say that updates should not be run while using a KVM, which is what I use, so I’ll have to collect a video lead, spare keyboard and mouse to do so. Hopefully be able to do that tomorrow.

What I am curious about is whether the layout of the EFI partition as shown above is correct - I took the option in the installer to mount it at /boot/efi

@manuel

I have access to change boot order without needing any sort of password. Trouble is, the only EFI boot option shown is the Windows boot loader. No idea why that should be, other than ancient firmware.

Hopefully I can put the more recent firmware in place tomorrow, see if the options are any better.

I can’t really tell anything from looking at the way it’s mounted. It obviously is pointing to Windows boot. I think in the EFI partition if you look at it the files are there as it worked when it first booted but it changed when you booted into Windows. On Windows 10 there is a free version of easy UEFI that you can down load from major geeks website. It allows you to view these entries and also move the position of Windows or grub up to be in the correct position. I use it sometimes because it’s an easy fix. I would try this and definately update the UEFI BIOS. Worse case I would reinstall grub according to the instructions on the Endeavour wiki. If you have Windows 10 booting try easy UEFI first. It’s easy to just move grub to first boot position and Windows second. This will work if everything is still intact but just not configured properly. This is not the first time I’ve seen this happen.

:slight_smile: Sounds good. I’ll give easy UEFI a try first, though I think I will almost certainly need to update the machine BIOS once I’ve got the necessary bits to do it correctly.

This was partially a learning exercise, and partially in preparation for a new machine, which will hopefully be here in a few days. It may not have the same problems…

Thanks! Easy UEFI did the trick. It could see both the Windows boot manager and EndevourOS entries. Moved the EndevourOS entry up and it seems to have done the trick. Tried rebooting several times and each time the grub menu comes up. I would love to know why it changed in the first place…

I will upgrade the firmware (well, make that maybe) if I can work out exactly what I need to upgrade. I had a look at the HP website and what I thought was a BIOS update seems to be an updated set of firmware tools. For one of the newer machines (8300 elite desktop) there is a firmware update listed, which probably makes sense, since the BIOS in my machine seems to be later than any BIOS release listed. Not at all confusing, of course…

I’m glad it worked. So you should have endeavouros or grub as the top entry and then Windows. The rest really doesn’t matter so much because they could be DVD drive etc. or another hard drive! UEFI keeps a running list and anything you plug in such as a usb drive will show up in that list of boot order. Sometimes Windows just decides to take over. I have had it happen to me hence why i have easy uefi to just easily correct it. It’s not happening much anymore as i figured out all the intricacies of UEFI as this was my first UEFI motherboard since 2006. I have read everything and anything to do with UEFI so i have a pretty good understanding now. Arch doesn’t make things easy either.

1 Like