Pop-up windows partially shown with a stuttering animation

All pop-up windows in Gnome or GTK seem to appear in a smaller window than the correct size, and only partially visible, until I move the mouse over it. How to fix this?

Gnome, Wayland, Nvidia, Fractional scaling 175%. I had installed Manjaro on the same PC with the same settings, and I never had this problem on Manjaro. Below is an example of the text editor’s save dialogue, but it also happened with other pop-ups like the shortcut input dialogue in the Keyboard settings.

Just as a trouble shooting step, set Fractional scaling back to 100% and see if
the problem goes away.


1 Like

I set 100%, and the problem seemed to disappear (although the very scaling selection drop-down menu itself appeared at a wrong position once – from second time, it was normal). But again, I did not have this problem when on the same PC I had set 175% in Manjaro, which, I think uses the same Gnome 43.2.

Is EndeavourOS configured something differently regarding to window default position/size, etc? I noticed that some default Gnome applications are different (Manjaro seems to be using older versions for the text editor, system monitor, terminal, etc).

PS: It also does not happen if the 175% is the only monitor. I currently am using dual monitors, one is 100% on the left, and the other is 175% on the right. It is not because of Gnome extensions, because it happened with all extensions disabled.

I have a similar problem with my Windows 11 machine which I use at work. I use dual monitors but the two monitors are a bit different. The one on my laptop is 4K but my second monitor is 1080p. So, applications windows have some problems scaling them selfs properly.

As you know, unlike Manjaro’s GNOME, :enos: GNOME setup is vanilla. There’s no custom setup that goes into it. And :enos: pulls down whatever the latest and grates available in the upstream repos. Manjaro uses the one they configured for Manjaro. And they kind of have the habit of using their own repo’s other than using Arch or other repo’s.

So, there might be a difference between how GNOME in Manjaro works and the vanilla GNOME works. That might be why you see a scaling issue with :enos: and not in Manjaro.

Manjaro tries to be an open-source Windows. Endeavour provides a base platform to build your own with a small number of tools.

Seems like it is either a bug of Gnome 43.2, GTK4, or Nvidia proprietary driver.

I installed the latest Fedora (37) on the same PC. It defaulted to Wayland using Nouveau. Immediately after installation, I set the same resolutions (100% and 175%), and checked the version of Gnome. It was 43.0. I tested for this bug, and it did not happen.

Now, I updated Fedora (there was some 1GB+ updates right after installation) and installed Nvidia proprietary driver. I rebooted and now Gnome’s version was 43.2, and the same problem happened. Oh well, I hope Gnome team or Nvidia would fix this soon…

I tested it again, and it happens on Manjaro, too. I just not noticed that I mainly used Manjaro on another computer with an Intel CPU and a single monitor, and Manjaro’s default Gnome apps are the old ones, which I think are using GTK3. This problem only seems to happen with new apps, which I think are using GTK4.

If you uninstall Nvidia drivers, does it keep happening?

Well, the answer seems “NO”.

I had installed both EOS and Fedora on the same disk, but updating Fedora’s grub somehow erased EOS’ system-boot entry, so I could not boot into EOS, and I had run complicated steps to install Nvidia driver, so rather than trying to undo all those steps, I just reinstalled Fedora. I chose Fedora, because it uses Wayland by default unlike EOS, so it would be easier to test.

I install Fedora 37, updated it to the latest (kernel 6.1 and Gnome 43.2, I think), and did nothing but enabling fractional scaling and setting 100%, 175% scaling and correcting monitor positions (1 is on the right, 2 is on the left). And the problem did not occur (see the screenshot below). The problem is that I cannot use Nouveau, because Blender does not work with it.