Poor video and graphics performance

Hello! I recently installed EndeavourOS and I have terrible graphics performance. The desktop lags and every video i try to play whether it be streamed on youtube or local runs at 1 fps it seems. I have an nvidia GPU, 780 ti, and i installed the drivers the way the wiki described by using the nvidia-installer.

I googled around to see if I could find a solution but nothing works.

System journal: https://pastebin.com/BRXpWpwN
Xorg: https://pastebin.com/USWk3S2r

Thank you for your time.

Welcome @Arviel !

pacman -Qs nvidia

Edito: pacman -Qs Nvidia no -Qm

Thank you!

Here is what i got back:

nvidia-dkms 440.59-3

I also tried to install the non-dkms drivers and that did not change anything.

I think those drivers are not the best for your card. They are for newer cards (10xx and 20xx GPUs). Check out the drivers download page of nvidia. Enter your card gen and select linux operating system and see which driver nvidia recommends. Keep the information in mind and go back and install that driver via packman from the official arch repositories removing nvidia-440 driver while you’re at it.

That was the first thing I did actually. Nvidia recommends the latest drivers for my card, 440.59.

I also tried doing the offline install just in case something went wrong with the net installer and the problem remains.

I know it is not the hardware as it is working fine under windows running the latest drivers.

Yeah I guess I had this wrong, confusing the 6000 and 7000 series with 600 and 700.
Did anything here https://wiki.archlinux.org/index.php/NVIDIA have any effect on your gpu situation?

Are you on Deepin desktop?

@nate I went over the wiki and I couldn’t find anything that worked.

@ricklinux Initially I was. I reinstalled and now using the xcfe version (it is quite nice!) just in case reinstalling might magically fix it.

Here is the latest xorg log: https://pastebin.com/fwBe8MDE
and system journal: https://pastebin.com/UUfyKtyz

EDIT: I just noticed that I can’t even play music as well.

Feb 06 14:23:22 buffy-pc kernel: ACPI: Added _OSI(Linux-HPI-Hybrid-Graphics)
Feb 06 14:23:24 buffy-pc kernel: nvidia: module verification failed: signature and/or required key missing - tainting kernel

would be more interesting to get information about hardware itself:

lspci 
lsusb

my it is a hybrid graphics notebook (model and manufacturer?)

Umm. Looks like my post were flagged as spam? I can’t post pastbin anymore.

I am also using a desktop pc.

EDIT: Seems okay now, anyways, here is the pastbin:

Here are the results: https://pastebin.com/PLbZF6Wy
screenfetch: https://pastebin.com/WdKiABBk

As far as I know the i7 4930k does not have an iGPU.

EDIT 2: Well whale wale. Things just got more interesting. I decided to remove the nvidia proprietary drivers and install the open source ones to see if that did anything. Now I get nothing but a black screen. Wish I had an amd card.

Anyways, unfortunately I have to put the Linux switch on hold and go back to windows until I get a different gpu/more compatible hardware. Thank you to all those that tried to help, greatly appreciate! I’ll definitely would like to give this distro another try in the future.

pastbin.com is not that save :wink:

you can take this:

lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F 'f:1=<-' ix.io
1 Like

If you get a newer Nvidia GTX 1650 TI or something should be good.

Edit: Please post the output as @joekamprad has given you as it will provide a link.

Hi, try and run other distros in live mode and see if you get the same issue?