Plasma-wayland-session changes GTK default to Xwayland

I do use KDE plasma, so I am not sure if this also occurs on other Desktop Environments.

This is a security concern, since users expect at least browsers like firefox to start with Wayland.

One can check that for example firefox does not start with Wayland with xeyes or xlsclients (restart before xlsclients has full output).

Manually setting

export QT_QPA_PLATFORM=wayland
export GDK_BACKEND=wayland
export CLUTTER_BACKEND=wayland

mitigates the issue.
Probably setting /etc/environment might be a better way.

The default behavior of GTK3 is to create a Wayland session, so the behavior is very odd. Checking the desktop files also shows no special attributes.

printenv shows that GDK_BACKEND is not set per default.
The configurations of GTK neither indicate programs to use x11.

Can anybody reproduce? Is this firefox specific?

Hello @matu3ba
Why are you saying users expect at least browsers like Firefox to start with Wayland? I am using Plasma and i am not using Wayland so are you saying those who are using Wayland expect this? Because i am using x11. This might be confusing to some users on plasma. Just want to understand what you mean.

2 Likes

plasma use a seporate session file is not enabled from start to use wayland, as user you have to install the plasma wayland session file what firefox behave like this idk…:slight_smile:

Isn’t this just how Firefox works?

I thought Firefox defaulted to X11 by default in a mixed environment?

Thanks. I do agree that, when an application wants users to opt-in(due to bugs of the application) the platform/distribution should not and can not handle all applications individually. I would have wished that the Wayland standard gives guarantees about application behavior (for example that the application must indicate that Xwayland is used in contrast to Wayland) for security of users.