Plasma starting slowly - one more possible cause (with solution)

Hi all,

I just wanted to share the result/solution of my many hours investigation.

Symptom: Plasmashell / Workspace needs 10 to 15 seconds more to load after logging in via SDDM. This happened with no update all of a sudden.

Disabling autostart programs, checking (disabling/enabling by rename) of .config files, disabling startup screen, … all of the many tips in the web did not help. Furthermore the “journalctl -b 0” output just had a 10 second gap - nothing in there, no hint, no severe errors.

Long story short: in the end I found that Klipper - the very useful clipboard manager - was the culprit. Somehow I managed to fill up it’s storage file in .local/share/klipper to somewhat around 300MB (may be copied a giant logfile - don’t know).

After deleting this file startup of plasmashell / plasmaworkspace was fast again.

I just want to share this just in case somebody else is struggling with slow startup times. This is a very hard to examine topic and my solution can be checked easily.

Hope it helps anybody while googling for a solution :slight_smile:


Hi Peter,

Thank you very much for sharing this solution, I have had a slow start of my plasma session, totally random.

I will keep this solution in mind in case it happens again.

The funny thing is that I have it configured in the settings that when a new session starts it starts all new, so I don’t know exactly what it would have to do with the slowness.

i guess disabling clipboard history will prevent this from happening again?

A new plasma session just won’t start manually opened programs that were still running when logging out or shutting down. This doesn’t affect programs in autostart and plasmoids.

So Klipper starts always and (if configured to keep history) will then load all stuff from it’s history file. If you don’t need a presistent history just uncheck the box in Klipper’s settings.

1 Like

If I have klipper do not save the history. So I have no problem in this case

Thank you Peter