Plasma language issues after the first logout

I have installed EndeavourOS with Plasma desktop, in Russian. The thing is, after the first logout and login, some parts of the UI are now in English, while others stay in Russian (screenshots attached). Context menus have become English too. Before the logout everything was totally normal and it stayed like that even after couple of restarts, but logging out manually broke everything.


never have I experienced something like that with Plasma, and it’s really annoying.:smiley:
what could be the fix?

Urgh! That sounds like a bug. I’d report that to KDE if it were me. Maybe not a bug as such, but just some lazy coding. Yeah we know English is pretty much the global language in computing these days but other languages should be respected too.

seems like I’ll have to stay in an English system for some time. time for a report!

run the following command in terminal and show us the result:

locale

sorry i forgot, welcome to EOS :wink:

hey. I’ve already managed to reinstall the system twice :smile:, now in English, but I’ve checked ‘locale’ before and it showed that everything was set to ru_RU.UTF-8 (as it should be?). most probably a bug with plasmashell (??) or whatever.

thanks for the warm welcome btw! actually am using EOS for a year already, best distro I know.

1 Like

Before the logout everything was totally normal

than it’s possible to fix it.

you have try to change the settings in the KDE GUI?

https://userbase.kde.org/Tutorials/Change_Plasma_Language

yeah, I did. the thing is, I’ve tweaked those settings, logged out and in, restarted, but nothing really changed. I’ve managed to set the system to English and revert it back to Russian/English, as above. I also tried to edit locale.gen → edit locale.conf → run locale-gen and logout login, but it didn’t help me either.

edit: i’ll set up a virtual machine later just to normally reproduce the issue and actually try to fix it with you. need just an hour or so.

please run this command:

ls -la $HOME/.config | grep locale

to search for a locale file into your .configs folder and show me what the file contains.

Although it may be a bug, not everything is broken :wink:
It could be a cache issue (you can clear it, especially if you have just upgraded to a new Plasma/KDE version packages, which you did not mention…)
I would first check upstream Plasma bugs for a similar open issue.