Plasma is killing apps

I’ve installed a couple of flatpaks and the first time I run them I get a notification form plasma workspace saying it’s running in the background. Well I didn’t click allow quick enough and now it’s being killed by plasma. How can I reset this?

Just wondering why do you want to use flatpaks? I have kde plasma running and it is flawless. It is fast, fluid, responsive and has no issues. I use packages that are in the repos or in the AUR.

3 Likes

I ordinarily run native packages, I only really have a couple of flatpaks which I thought were simpler to use. But when I tried to run a game I I had installed this happened and now I’m down the rabbit hole and I’m really more interested in how to fix this than the actual flatpak

So what is actually happening then?

Edit: Can’t you just uninstall the flatpaks and see if the issue goes away?

Be specific.

What flatpaks? Installed from flathub?

What error message? Is there a log message? Did the flatpak app segfault? If so what is the error message?

Find it hard to believe Plasma, or any DE, is “killing” flatpak apps.

It was a couple of gnome games 2048 and some other puzzle game that the name is escaping me at the moment. No seg fault no error messages, and it’s definitely plasma killing it. I got the same message for Cawbird but I managed to hit the allow button when it popped up and that app remains running. I’ll take a screen shot of what pops up later today and post it. Hopefully that will help.

Try running them from the terminal using flatpak run and see if you get any better error messages that way.

Tried that no information unless there is some verbose switch I can use I just ran them with the run switch

-vv

I’ll give that a try and report back

ran flatpak run -vv org.gnome.TwentyFortyEight and again no error message the app just closes

Try installing a known working flatpak like firefox.

Tried with firefox and I get the same issue. I am attaching two screen shots, The first shows the initial dialog (sorry its for a different porgram, couldn’t his screen capture fast enough) and the second is after hitting “find out more” button when running firefox. this is what I am tring to fix.
Screenshot_20210331_101248_message|534x286

The second image didn’t upload

Screenshot_20210331_101248_message

That is really strange. I don’t think plasma is killing it. I think it the UI is crashing for some reason.

An interesting test would be to create a new user account. Login to the new user and see if works there. That will tell you if it is an issue with your cache/settings or a system wide issue.

2 Likes

I just created a new regular user and still the same issue. Attaching screen shots is what I got with the new user.

thanks @dalto finally got it working. So it ends up its not really a plasma issue like I thought but really a flatpak issue as you thought. to fix it I removed my .local/share/flatpak/db folder and that reset everything. Flatpak still asks if it can run in the background, which I suspect is a xdg-desktop-portal-kde issue, but now I select allow and that fixes it.

2 Likes