Plasma broken even after reinstall

Hello again!

Some of you might already know that I have issues with Plasma, but I moved the subject here, since it seems to fit the best.

So, as already described partially here, before, and after going an EOS reinstallation, Plasma has serious issues.
It was fine for one day, and now, it start’s being nuts again.

Here’s a list of the issues I found:

  • No audio.
  • Only 2 display’s (1 external + laptop) The third display get signal, but doesn’t get refreshed.
  • GUI bugs as shown in the picture’s.

What I’ve already tried:

  • Using the vanilla, and zen kernel.
  • Pluging (physically) a screen in and out.
  • Changing Plasma’s global theme.

I have absolutely no idea if this is a Plasma, Kernel, Driver, or maybe a mix of all issue.

Plasma version: 5.26.5
Window Manager: KWin
Kernel: 6.1.6 (zen)

I took the drive where EOS’s installed, booted it on another PC and it works just fine.
Put it back to the issue PC, and now, it looks even worse. :smiling_face_with_tear:

What does systemctl --user status pipewire.service return?

luxi@endeavouros ~ [1]> sudo systemctl --user status pipewire.service
Failed to connect to bus: No medium found.
luxi@endeavouros ~ [1]> systemctl --user status pipewire.service
● pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; preset: enabled)
     Active: active (running) since Sun 2023-01-15 22:49:39 CET; 57s ago
TriggeredBy: ● pipewire.socket
   Main PID: 1719 (pipewire)
      Tasks: 3 (limit: 18302)
     Memory: 11.2M
        CPU: 168ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─1719 /usr/bin/pipewire

jan 15 22:49:39 endeavouros systemd[1125]: Started PipeWire Multimedia Service.
jan 15 22:49:39 endeavouros pipewire[1719]: mod.rt: Can't find org.freedesktop.portal.Desktop. Is xdg-desktop-portal running?
jan 15 22:49:39 endeavouros pipewire[1719]: mod.rt: found session bus but no portal
jan 15 22:49:40 endeavouros pipewire[1719]: [0:00:29.789755852] [1719]  INFO Camera camera_manager.cpp:299 libcamera v0.0.3

What does systemctl --user status xdg-desktop-portal return?

Sorry, I’ll tell you that tommorow, I just shut down the computer, because it’s already late for me. ^^’

luxi@endeavouros ~ [1]> systemctl --user status xdg-desktop-portal
Unit xdg-desktop-portal.service could not be found.

My bad. I think KDE uses xdg-desktop-portal-kde.
What does systemctl --user status xdg-desktop-portal-kde return?

hardware will be the issue here i bet some 12 gen intel GPU?
inxi -Fxxc0z | eos-sendlog

luxi@endeavouros ~> systemctl --user status xdg-desktop-portal-kde
Unit xdg-desktop-portal-kde.service could not be found.

Actually, It has issues on an R7 4800H, but works on an i5-6500T machine.

The audio issues are solved, the devices were just all muted, it’s just pretty hard to see with the icons missing. :upside_down_face:

  1. AMD Ryzen 7 4800H with Radeon Graphics
  2. NVIDIA TU117M [GeForce GTX 1650 Ti Mobile]

looks like hybrid GPU?

It is, I also have Optimus-Manager(-qt).
Should I try to switch between the GPU’s?

at least this would hint on why the display is not showing up… it is connected to nvidia GPU…

Both output (HDMI & DP) are wired to the Nvidia card.
But it’s weird that only one of them works.

The laptop screen is hooked up to both cards.

Did you go into KDE settings display and check?

Alright, so I switched to Integrated, then Nvidia, then back to Hybrid, and they all worked, I can even use the third display.

But lemme do a restart if it stay’s in working order.

Yep, all of them are enabled.

Yes, and no, the desktop is fine, but one screen isn’t working, so I guess it’s just a matter of time until it breaks again.

So I tried things that seem to work, though, I would prefer not to use it.
After boot, one of the screens isn’t working, so I change Optimus to “Integrated” (“Nvidia” works too I think), log back in, and it works, though, it falls back to the “Hybrid” mode.

New update.
So the method above doesn’t work anymore, and apparently, putting the PC to sleep, and waking it up solves the problem.