Plasma broke on AMDGPU?

I’ve got Endeavour on 3 laptops. 2/3 are working just fine. The 3rd will NOT log into the desktop. The 2 that work fine are Intel CPU/GPU, the 3rd is a AMD CPU/GPU (T14 AMD specifically). SDDM starts just fine. You can log in, it changes the mouse cursor to your theme, and then just displays a black screen otherwise. Pressing the power button DOES bring up the “logout” menu properly, and the mouse cursor nerver freezes. I created a test user and tried logging in with that, same thing, so not a user configuration for anything Plasma. Any ideas, or anyone seeing the same?
This happened last night, so whatever broke it happened last time I updated prior to last night. I tried doing updates to see if whatever caused it was already fixed, but no go.

try in .config/kwinrc to disable composition ?

Nope, doesn’t change anything.

I have an 1800x and vega 64 no issues. I think that maybe your theming may have an issue. Did you try using say breeze / default?

Yes, a brand new user with all defaults it happens to.

Did you try a different kernel?

I have tried it, but LTS kernel doesn’t even boot on this machine.

Hardware specs (ie inxi)? Is this laptop very new?

Log messages (ie kernel log, journal log, xorg log)?

Without any details it is almost impossible to help you.

Another suggestion, rule out plasma, install another DE, say LXDE and boot to that.