Plasma 6 Wayland Issues

Hello!
I tried several times to switch to wayland before, but every time have many issues that force me to postpone it and continue to use x11. Obviously wayland is now a default choice for plasma and I guess new features mostly comes to it. And now I trying again to resolve those issues as I can.

Firstly, I specifically updated (for now), I didn’t reinstall the system. Worth mentioning that I use 125% scaling as I am using 27 inches 2K monitor, because elements is to small at 100%. I am pretty much average linux user, not afraid of terminal, but I am not into specific details about it. I will describe some issues I faced, some of them I resolved but I will mention them anyway (who knows, maybe there are some other solutions to them)

First issue was broken login screen, it has like old version of it and there was notice that The current theme cannot be loaded due to the errors below, please select another theme. And there was two qml-files in the sddm directory and something about Library import requires a version.
It fixed itself after reboot.

Another partly fixed issue is insane pointer (mouse) behavior. It really was good on x11 and I has no issues about it (don’t even configure anything). But on wayland it just “jumpy” or something like that. When I disabled acceleration, it just very slow. Pointer speed configuration also affecting not what I want. I am still thinking its the weird acceleration, but enable or disable it not enough. I installed Piper application as I use Logitech G102. For some reason it shows that mouse use 1600 dpi (when I use it on 3200 dpi). Changing dpi in this app make mouse behavior better but still not like it was on x11. I guess maybe I will adapt with some time.

Next one issue maybe related to more of plasma itself. Screen edge feature working wrong. I configure to use Overview at the left upper edge and also I am using task panel at top. So when I want to run application launcher it highlight that corner for the screen edge feature. And it works if you move pointer close to corner, but when you try to click on application launcher icon (when it highlighted) for some reason it either do nothing or bring me Guake Terminal which is hide in tray menu. If I disable screen edges features it don’t do that anymore. But with it enabled it start doing it again. I don’t understand why. If it bring overview, but some other application. Weird.
image
UPDATE: It might be problem from guake itself, it pops out even when screen edges are disabled and panel is moved.

Issue with shortcuts. So, I heard that gestures and shortcuts are supposed to be better in wayland. But in mentioned Guake Terminal the shortcut for popout terminal is not working. I fixed it by adding custom shortcut command guake -t, but it just a workaround. It’s not a solution. And yes, I use specifically guake on Plasma, because it has features that yakuake hasn’t. The feature of saving and restoring sessions in yakuake stuck like for several years already.

Also there is problem with steam not scaling properly. I had this issue on x11, but with some updates to steam it was fixed. Now the same thing in wayland. But I guess that related to steam itself.

There are more issues, but these are some of them that concern me in a daily routine. Sorry, if I put this topic in a wrong way, I understand that probably it more related to wayland topic and my problems with it. But I appreciate any useful tips and solutions.

Thank you!

P.S. And I am sorry for my English, it’s not my first language and I am still learning.

  1. The theme issue means that your theme hasn’t been ported to plasma 6, so switch back to breeze until whoever made the theme updates it.
  2. Not sure about the mouse thing. I thought it felt more snappy, but I just got used to it. Feels fine to me.
  3. I’m not really understanding what you are saying about the screen edge feature. You say it is working wrong, but you describe your issue is with doing stuff on the panel and not anything to do with the screen edges feature. All I really got from it was that the issue you are having doesn’t happen when the screen edge feature is turned off. I moved my panel to the top. I use yakuake and not guake so not sure about that. I can trigger the application launcher just fine. Overall I’m not sure of the problem here.
  4. Again I’m not sure about the guake thing. Is their an entry for that in the shortcuts settings that isn’t working? Did you try resetting it?
  5. There has been a bug about steam scaling open ever since the redesign. Don’t hold your breath on that one.
  1. As I mentioned it fixed itself after reload. I mentioned it because I looking for tips in forum on this, but didn’t find any. Then reboot and the login screen are okay now. I didn’t use any other login screen from default, it the same breeze but I only changed background image.
  2. Well, than I probably will adapt too.
  3. I I jumped to conclusions too soon. In update I wrote that it probably something with guake itself on wayland, I already report it. I think it buggy tray icon, because that invisible spot in top left edge has same behaviour as tray icon (it has same context menu).
  4. It’s about shortcut overall, I used guake as example. It seems shortcuts not working well on wayland, because I have similar issue with keepassxc (there are no even settings for autotyping now, but it probably because of the security thing). And I used shortcut for walking through desktops on Meta + Tab. I checked system settings for this shortcut, it all set correct, but shortcut just not working. It didn’t react at all.
  5. For this one find solution by adding environmental variable STEAM_FORCE_DESKTOPUI_SCALING=1.25 and to my surprise it works. I remember that fraction scaling variable usually didn’t work on steam.

Thank you for reply!

No problem. About point number 4, I don’t see a walk through desktops. There is a walk through activities and a walk through windows, but not a walkthrough desktops. For that one are you sure that still exists on plasma 6?

They already know that it is for gnome and gave reasons why they use it on kde anyways.

1 Like

Tile Window Adjustment Key Issue
meta +t
Cause system down

System:
Host: buster-b350gt3 Kernel: 6.7.9-arch1-1 arch: x86_64 bits: 64
compiler: gcc v: 13.2.1 clocksource: tsc
Desktop: KDE Plasma v: 6.0.1 tk: Qt v: N/A wm: kwin_wayland dm: 1: LightDM
v: 1.32.0 note: stopped 2: SDDM Distro: EndeavourOS base: Arch Linux
Machine:
Type: Desktop Mobo: BIOSTAR model: B350GT3 serial: N/A
uuid: 03000200-0400-0500-0006-000700080009 UEFI: American Megatrends LLC.
v: 5.17 date: 05/23/2022
Memory:
System RAM: total: 16 GiB available: 15.56 GiB used: 3.21 GiB (20.6%)
Array-1: capacity: 128 GiB slots: 4 modules: 2 EC: None
max-module-size: 32 GiB note: est.
Device-1: Channel-A DIMM 0 type: no module installed
Device-2: Channel-A DIMM 1 type: no module installed
Device-3: Channel-B DIMM 0 type: DDR4 detail: synchronous unbuffered
(unregistered) size: 8 GiB speed: 2800 MT/s volts: 1.2 width (bits):
data: 64 total: 64 manufacturer: Samsung part-no: M378A1K43CB2-CRC
serial: 34E88BE2
Device-4: Channel-B DIMM 1 type: DDR4 detail: synchronous unbuffered
(unregistered) size: 8 GiB speed: 2800 MT/s volts: 1.2 width (bits):
data: 64 total: 64 manufacturer: Samsung part-no: M378A1K43CB2-CRC
serial: 34E88702
CPU:
Info: 6-core model: AMD Ryzen 5 1600 bits: 64 type: MT MCP smt: enabled
arch: Zen rev: 1 cache: L1: 576 KiB L2: 3 MiB L3: 16 MiB
Speed (MHz): avg: 1654 high: 2800 min/max: 1550/3600 boost: disabled
volts: 1.2 V ext-clock: 100 MHz cores: 1: 1550 2: 1550 3: 1550 4: 1550
5: 1550 6: 1550 7: 1550 8: 1550 9: 2800 10: 1550 11: 1550 12: 1550
bogomips: 76682
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
Device-1: NVIDIA TU106 [GeForce RTX 2060 Rev. A] driver: nvidia v: 550.54.14
arch: Turing pcie: speed: 2.5 GT/s lanes: 16 ports: active: none
off: DVI-D-1,HDMI-A-1 empty: DP-1 bus-ID: 07:00.0 chip-ID: 10de:1f08
class-ID: 0300
Display: server: X.Org v: 23.2.4 with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia,nvidia-nvswitch
display-ID: :1 screens: 1
Screen-1: 0 s-res: 3600x1080 s-dpi: 96 s-size: 953x286mm (37.52x11.26")
s-diag: 995mm (39.17")
Monitor-1: DVI-D-1 note: disabled pos: left model: LG (GoldStar) EX221
serial: 405NDMT2U459 res: 1680x1050 hz: 60 dpi: 91
size: 470x290mm (18.5x11.42") diag: 552mm (21.7") modes: max: 1680x1050
min: 640x480
Monitor-2: HDMI-A-1 note: disabled pos: primary,right model: BenQ GW2470
serial: 95H01983019 res: 1920x1080 hz: 60 dpi: 92
size: 530x300mm (20.87x11.81") diag: 604mm (23.8") modes: max: 1920x1080
min: 640x480
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia gbm:
drv: nvidia surfaceless: drv: nvidia inactive: wayland,x11,device-1,device-2
API: OpenGL v: 4.6.0 vendor: nvidia v: 550.54.14 glx-v: 1.4
direct-render: yes renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2
API: Vulkan v: 1.3.279 layers: 2 surfaces: xcb,xlib device: 0
type: discrete-gpu driver: nvidia device-ID: 10de:1f08
Audio:
Device-1: NVIDIA TU106 High Definition Audio driver: snd_hda_intel v: kernel
pcie: speed: 8 GT/s lanes: 16 bus-ID: 07:00.1 chip-ID: 10de:10f9
class-ID: 0403
Device-2: BEHRINGER GmbH UMC204HD 192k driver: snd-usb-audio type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 1-2:3 chip-ID: 1397:0508
class-ID: fe01
API: ALSA v: k6.7.9-arch1-1 status: kernel-api
Server-1: sndiod v: N/A status: off
Server-2: PipeWire v: 1.0.3 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
Network:
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: Biostar Microtech Intl Corp RTL8111/8168/8411 driver: r8169
v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 03:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: b8:97:5a:ef:8e:a0
Drives:
Local Storage: total: 2.84 TiB used: 208.11 GiB (7.2%)
ID-1: /dev/nvme0n1 vendor: Crucial model: CT1000P5PSSD8 size: 931.51 GiB
speed: 63.2 Gb/s lanes: 4 tech: SSD serial: 23153FF4EE37 fw-rev: P7CR402
temp: 55.9 C scheme: GPT
ID-2: /dev/sda vendor: Western Digital model: WD20PURX-64P6ZY0
size: 1.82 TiB speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: WD-WCC4M5DVRYPK
fw-rev: 0A80 scheme: GPT
ID-3: /dev/sdb vendor: Samsung model: HM12HII size: 111.79 GiB
speed: 1.5 Gb/s tech: N/A serial: S14EJD0P907043 fw-rev: 0-09 scheme: MBR
Partition:
ID-1: / size: 896.12 GiB used: 207.86 GiB (23.2%) fs: btrfs
dev: /dev/nvme0n1p2
ID-2: /home size: 896.12 GiB used: 207.86 GiB (23.2%) fs: btrfs
dev: /dev/nvme0n1p2
ID-3: /var/log size: 896.12 GiB used: 207.86 GiB (23.2%) fs: btrfs
dev: /dev/nvme0n1p2
Swap:
ID-1: swap-1 type: partition size: 34.41 GiB used: 21.2 MiB (0.1%)
priority: -2 dev: /dev/nvme0n1p3
Sensors:
System Temperatures: cpu: 46.2 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Processes: 385 Power: uptime: 3m states: freeze,mem,disk suspend: deep
wakeups: 0 hibernate: platform Init: systemd v: 255 default: graphical
Packages: 1444 pm: pacman pkgs: 1430 pm: flatpak pkgs: 14 Compilers:
gcc: 13.2.1 Shell: Sudo (sudo) v: 1.9.15p5 default: Bash v: 5.2.26
running-in: xfce4-terminal inxi: 3.3.33

Well, it was doing well before update or rather it related to wayland. Gonna later check how this work on x11. Either way it still present in shortcut list for KWin:

That is kinda weird. Here is what mine looks like


I have walk through windows and applications, but not desktops.

Yes I don’t have the Walk through desktops either

1 Like

Seeing as to how me and @smokey don’t have those shortcuts, I believe those are leftovers from khotkeys which is umaintained and has been removed. I wonder if we can reset your shortcuts or delete the configs for it and have you use the next and previous desktop shortcuts that I see on my system instead.

1 Like

Indeed, weird. The shortcuts I use for desktops are default for activities, but I disable them and reassign to desktops. I doubt that developers remove those shortcuts, desktops are even more usable considering better overview feature in new plasma. Can you check those shortcuts without search?

About previous and next desktops, I have these shortcuts. Still I prefer to use “walk through” because that goes though desktop list on loop, but “next desktop” will not go to the first desktop if I currently at the end of list.

That’s how I checked, they’re in Alphabetical order so I don’t think I missed seeing them

1 Like

It’s more weird… I tried to set these shortcuts to “switch and previous desktop” and it didn’t work either. Than I tried different combination of buttons, also didn’t work. Then I returned to Meta + Tab and it suddenly works.

Also for some reason “Kwin” become “System Settings” menu… Now it have two menu options named “System Settings”.

1 Like

I probably should make a clean install of the OS… It seems that Alt+Tab is broken too.

Before you do that, have you tried it with a new user?

1 Like

No. I will try it. Anyway, maybe rebooting help to fix these weird things with names and Alt+Tab

Logging in and out should be enough

Well, Kwin is back, but Alt + Tab still broken. It just show an empty rectangle where suppose to be list of windows.

Not that it matters, but I’d just add that mine looks identical with @d-air1 and @smokey. I’ve not had any issues with kwin, thankfully.

1 Like

I second @smokey idea of trying with a new user. Seems like some file is borked.