Plasma 6 shutdown not working after latest update

After an update just a few days ago, Plasma’s shutdown button does not shut the system down, it just puts it into a weird “halfway shut down” condition – the screen goes black but the mouse pointer is still visible, my screensaver starts after the usual time with no input, but it never completes the shutdown, even after a half hour or so. I can log into another TTY and shut it down with the shutdown terminal command, or I can just use the shutdown terminal command in a console instead of the menu shutdown button.
Another problem that happened about the same time, probably with the same update, is that System Settings has some really weird bugs: choosing a few different categories one after the other starts giving the error message “Error loading QML file.” even if I haven’t made any changes in any of the categories I’ve selected. e.g., selecting Mouse & Touchpad->Screen Edges, then back to Sound on the root list, gives me that error.
These problems happen on two different systems: a recent ASUS MB with a 14th-gen Intel processor, and a 2-year-old Gigabyte MB with an AMD processor, both using X11, not Wayland (which has many more problems!) Hopefully a fix for these issues is in the works. I have a workaround for the shutdown problem – does anyone know of a workaround for the Settings problem?


Also having the issue with shutting down and rebooting. But don’t see errors in settings.

Some details about my system:
Operating System: EndeavourOS
KDE Plasma Version: 6.1.0
KDE Frameworks Version: 6.3.0
Qt Version: 6.7.2
Kernel Version: 6.9.6-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 3700X 8-Core Processor
Memory: 62,8 GiB of RAM
Graphics Processor: AMD Radeon RX 7900 XTX
Manufacturer: Micro-Star International Co., Ltd
Product Name: MS-7B86
System Version: 2.0

I’ve got the exact same problem on my desktop and laptop.
It’s “fixed” when I enable Wayland and returns on X11.

I filed a bug report:

1 Like

Since Wayland has multiple other problems on my system, I didn’t try it. Instead, I’ve used eos-shifttime to backrev to June 11th on both systems and everything is working normally again. The only problem with doing that is that Firefox loses all its customizations, passwords, etc, and has to be set up again; I don’t use Firefox sync for security reasons, but I suppose that would fix that problem.
Thanks for filing the bug report; I didn’t know how.

Hello Hello,

I’ve got EXACTLY the same issue by now …
I will try to open a session on Wayland reboot and then swith back to X11 to see.
But I can’t stay on Wayland by now, Nvidia, Games … :roll_eyes:

I never had this problem before, so I suppose it is linked to a recent update …

I will keep you informed, but if anybody has any idea/solution…
Thanks to him =D

Ps : My last inxi

Hey guys just checking, did you happen to have a kernel update at the same time? And does using a different kernel solve?

I didn’t check to see what kernel was in use when I was having the problems; sorry, my bad! Now that I’m backrevved and everything is working as it should, here’s what fastfetch tells me about my system:

OS: EndeavourOS rolling x86_64
Kernel: Linux 6.6.32-1-lts
Uptime: 19 mins
Packages: 1453 (pacman)
Shell: bash 5.2.26
Display (DELL UP2720Q): 3840x2160 @ 60Hz *
Display (DELL U4320Q): 3840x2160 @ 60Hz
DE: KDE Plasma 6.0.5
WM: KWin (X11)
WM Theme: Breeze
Theme: Breeze (Light) [QT], Breeze [GTK2/3]
Icons: breeze [QT], breeze [GTK2/3/4]
Font: Noto Sans (10pt) [QT], Noto Sans (10pt) [GTK2/3/4]
Cursor: breeze (24px)
Terminal: xterm 392
Terminal Font: fixed (8.0pt)
CPU: Intel(R) Core™ i9-14900K (32) @ 6.00 GHz
GPU: NVIDIA GeForce RTX 3060 Ti [Discrete]
Memory: 4.17 GiB / 125.54 GiB (3%)
Swap: 0 B / 64.84 GiB (0%)
Disk (/): 20.24 GiB / 319.60 GiB (6%) - ext4
Disk (/home/grathbun): 41.78 GiB / 531.32 GiB (8%) - ext4
Disk (/home/grathbun/Data): 474.74 GiB / 732.29 GiB (65%) - ext4
Disk (/home/grathbun/DataArchive): 379.39 GiB / 936.82 GiB (40%) - ext4
Local IP (eno2): *
Locale: en_US.UTF-8

Here you are using the LTS the original showed using the main kernel which could explain this. I’'ve had minor things like this before which is why I have different kernels installed.

1 Like

I don’t know the pros and cons of using the LTS, I just checked the box for it to be installed during the initial installation, assuming the LTS would be the most stable.
I have a vmlinuz-linux and a vmlinuz-linux-lts, both 13M in size, and both dated Jun 25 at 16:25, which I assume are the installed kernels.
My older AMD system does not have the LTS kernel installed, and it showed the same symptoms as my main system (above). I don’t have fastfetch or neofetch installed on the old system, but here’s its basic info, from uname and inxi:

uname -a:
Linux LPWEndvr 6.9.3-arch1-1 #1 SMP PREEMPT_DYNAMIC Fri, 31 May 2024 15:14:45 +0000 x86_64 GNU/Linux

CPU: 16-core AMD Ryzen 9 3950X (-MT MCP-) speed/min/max: 2484/2200/4761 MHz
Kernel: 6.9.3-arch1-1 x86_64 Up: 11m Mem: 1.74/31.26 GiB (5.6%)
Storage: 1.34 TiB (2.3% used) Procs: 488 Shell: Bash inxi: 3.3.34

I appreciate your help, @smokey. Any recommedations?

Hello everyone !

Some testings done this morning :

Shutdown/reboot with X11-Linux : Not working.
Shutdown/reboot with X11-LTS : Not working.
Shutdown/reboot with Wayland-Linux : OK !
Shutdown/reboot with Wayland-LTS : OK !

Sooo : I suppose the problem is linked to X11, and not Linux Kernel or Endeavour distro.

Interessant thing : IF I enter directly Shutdown command in terminal in my current session, It works !

I think we need to focus on X11 config somewhere by now, but I cannot help you more, not enough knowings… :no_mouth:

You can always backrev using eos-shifttime. That’s what I did – went back to June 11 and everything’s working normally.

But eos-shifttime revert ALL packages of the system…

We only need to downgrade any “x11” package, No ?
If you know wich ones, I take the info :wink:

That’s right, eos-shifttime reverts everything. After reverting, I didn’t notice any difference in functionality of any package, except that I had to reconfigure Firefox, and the System Settings program went back to working normally.
There may be a way to revert just the X11 packages but I don’t know how. I suspect it would be pretty tedious.