Plasma 5.19 battery monitor does not detetct batteries anymore

Today, I noticed, that the battery monitor in plasma 5.19 does neither detect my laptop battery nor my mouse battery anymore.
Any ideas how to get that functionality back?

I just looked on mine and since upgrading to 5.19 my battery indicator is completely missing on my install now.

It just doesn’t show up, you have to reactivate it in the system tray icons after each reboot.

It actually did re-appear if I boot up on battery, but if I plug in so my batteries get to 100%, it disappears and then even if I unplug and the batteries start draining, it doesn’t come back.

I’m going to guess this is a bug in 5.19?

Gotta say, so far not impressed with the 5.19 release. Seems to be exceedingly bug-filled.

I agree, my thermal monitor can’t be configured anymore either, trying so makes my panels disappear and renders my desktop unreponsive, forcing me to reboot.

have you tried when it is power off to remove the battery for a few seconds and then reinsert it int the battery slot. Then you turn your system on again and check if it is detected ? This one worked for my Dell Inspiron laptop. The best and stay Home and safe.