Pipewire syslog warnings

i finally got around to installing pipewire on my system:

sudo pacman -S pipewire pipewire-pulse pipewire-alsa --needed

i also deleted ~/.config/pulse - now it only contains a new cookie file.

❯ pactl info
...
Server Name: PulseAudio (on PipeWire 0.3.24)
...

everything works fine (headphones, audio recording, playback, screen recording), no dropouts, crackling, lags.

first off - i don’t use bluetooth and have deactivated or removed it as far as possible - as i think this might be the cause for the warnings.

here are the ksystemlog error messages:

kernel	Bluetooth: hci0: unexpected event for opcode 0xfc2f
...
pipewire-media-session	GetManagedObjects() failed: org.freedesktop.DBus.Error.ServiceUnknown
...
pipewire-pulse	recv client:0x564... res -1: Connection reset by peer
pipewire-pulse	pulse-server 0x564...: client:0x564... [ALSA plug-in [deadbeef]] error -104 (Connection reset by peer)

the last ones show up several times when playing audio or recording in audacity for instance…

the bluetooth event I do not see for very long under 5.11.x.

how do you guys rate this, is it all just insignificant noise?

would like to stay with pipewire.

From just reading the error message it does indeed look like it’s looking for a bluetooth service and cannot find it.

Personally I would enable bluetooth to just see if it goes away, and if it does disable it again and just ignore it as long as it doesn’t hinder a function you need.

1 Like

have not done this for a long time, hope i have put the wiki steps correctly:

paru bluez bluez-utilz
modprobe btusb

❯ lsmod
Module                  Size  Used by
...
btusb                  69632  0
...

sudo systemctl enable bluetooth.service
sudo systemctl start bluetooth.service

bluetooth.service is Active: active (running)

reboot

the syslog messages are unfortunately the same.

1 Like

have you try.

systemctl --user start pipewire.service 
1 Like

in ksysguard these are active and running:

pipewire
pipewire-media-session
pipewire-pulse

from the wiki:

Install pipewire-pulse. It will replace pulseaudio and pulseaudio-bluetooth. Normally, no further action is needed, as the user service pipewire-pulse.socket should be enabled automatically by the package.

and

Summary
❯ systemctl --user status pipewire.socket
● pipewire.socket - Multimedia System
     Loaded: loaded (/usr/lib/systemd/user/pipewire.socket; enabled; vendor preset: enabled)
     Active: active (running)
   Triggers: ● pipewire.service
     Listen: /run/user/1000/pipewire-0 (Stream)
     CGroup: /user.slice/user-1000.slice/user@1000.service/app.slice/pipewire.socket

~ 
❯ systemctl --user status pipewire.service
● pipewire.service - Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; vendor preset: enabled)
     Active: active (running)
TriggeredBy: ● pipewire.socket
   Main PID: 1430 (pipewire)
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─1430 /usr/bin/pipewire

~ 
❯ systemctl --user status pipewire-pulse.service
● pipewire-pulse.service - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.service; disabled; vendor preset: enabled)
     Active: active (running)
TriggeredBy: ● pipewire-pulse.socket
   Main PID: 1415 (pipewire-pulse)
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire-pulse.service
             └─1415 /usr/bin/pipewire-pulse

pipewire-pulse[1415]: recv client:0x55e1878c9ad0 res -1: Connection reset by peer
pipewire-pulse[1415]: pulse-server 0x55e1877cac80: client:0x55e1878c9ad0 [ALSA plug-in [deadbeef]] error -104 (Connection reset by peer)
pipewire-pulse[1415]: recv client:0x55e1878d9620 res -1: Connection reset by peer
pipewire-pulse[1415]: pulse-server 0x55e1877cac80: client:0x55e1878d9620 [ALSA plug-in [deadbeef]] error -104 (Connection reset by peer)

             
❯ systemctl --user status pipewire-media-session.service
● pipewire-media-session.service - Multimedia Service Session Manager
     Loaded: loaded (/usr/lib/systemd/user/pipewire-media-session.service; enabled; vendor preset: enabled)
     Active: active (running)
   Main PID: 1431 (pipewire-media-)
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire-media-session.service
             └─1431 /usr/bin/pipewire-media-session

pipewire-media-session[1431]: oFono: Registering Profile /Profile/ofono failed
pipewire-media-session[1431]: hsphfpd: Registering application /Profile/hsphfpd/manager failed

what is the output with:

journalctl -ab | grep pipe

have you try to remove pipewire-pulse

i have install
pipewire
gst-plugin-pipewire
pipewire-media-session

and it work fine

❯ journalctl -ab | grep pipe
pipewire-media-session[1427]: oFono: Registering Profile /Profile/ofono failed
pipewire-media-session[1427]: hsphfpd: Registering application /Profile/hsphfpd/manager failed
pipewire-media-session[1427]: GetManagedObjects() failed: org.freedesktop.DBus.Error.ServiceUnknown

from what i could find out so far, the first 2 entries can be skimmed in my case.

no, to do what then further?

i tried to stay close to the wiki.

pipewire-media-session comes a dependency and gets installed automatically.

what is the benefit of having gst-plugin-pipewire around?

thanks, i know the thread from my search for the warning messages.

I am on Xfce and do not need a lot of fancy things, so I just installed

sudo pacman -S pipewire pipewire-pulse --needed

Confirmed the changes,
rebooted,
reinstalled

sudo pacman -S pavucontrol

(It worked without it, but I had no audio mixer settings so I couldn’t set my headphones as default output).

That’s it.

I also deleted my Pulse directory since it contained a .conf file specifically set to stop a bug from occurring where all sounds played too fast (everyone was on helium in videos and music basically) since the bug didn’t occur with pipewire.

i didn’t do much more - except for throwing pavucontrol down, the plasma mixer is enough for me :wink:

well, everything works so far and maybe one should give less importance to the messages.

i’ll keep testing and wait for an upcoming version…

the positive: the headphones are now crystal clear and have no more high noise and occasional crackles under wine are also gone.

pipewire is great.

1 Like

one last note and possibly of importance - with wine and foobar the messages do not show up, except for this one:

pipewire-pulse pulse-server 0x559064a064f0: [foobar2000.exe] UNDERFLOW channel:0 offset:5337088 underrun:2048

the arch wiki holds:

to solve this problem edit /etc/pipewire/media-session.d/alsa-monitor.conf, uncomment the line saying api.alsa.headroom = 0 and change its value to 1024.

not sure how high to set the value, but 4096 fixes this message.