Pipewire PulseAudio

Not really a question on something broken, KDE on EOS works like a charm, but why does Apollo still include Pulseaudio while I read that Pipewire replaced it? Not a criticism, just wondering. Sound works really well, even on my desktop with it’s exotic soundblaster card of Creative that shuns Linux.

1 Like

On Gnome, I have only pulseaudio-alsa which is a dependency of the DE:

 pactree -r pulseaudio-alsa
pulseaudio-alsa
└─gnome-settings-daemon
  ├─gnome-control-center
  │ └─gnome-calendar
  ├─gnome-shell
  │ ├─gdm
  │ ├─gnome-shell-extension-appindicator
  │ └─gnome-shell-extensions
  ├─gnome-tweaks
  └─mutter
    └─gnome-shell
4 Likes

Check if you are running pipewire pactl info

Since Atlantis you should be on pipewire if you installed EOS using the new iso.

2 Likes

Nice, I didn’t know pactree that’s handy.

2 Likes

Very nice for checking the dependencies and reverse dependencies of a package. Also for those in sync databases instead of local.

1 Like

this is the ouput of that command on a fresh install. I did switch to KDE though.

Blockquote Server String: /run/user/1000/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 1212
Tile Size: 65472
User Name: marnix
Host Name: marnix
Server Name: PulseAudio (on PipeWire 0.3.51)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_06_00.0.analog-stereo
Default Source: alsa_input.pci-0000_06_00.0.analog-stereo
Cookie: 8210:fe3e
Blockquote

PulseAudio clients

Install pipewire-pulse. It will replace pulseaudio and pulseaudio-bluetooth. Reboot, re-login or start the pipewire-pulse.service user unit to see the effect.

Normally, no further action is needed, as the user service pipewire-pulse.socket should be enabled automatically by the package. To check if the replacement is working, run the following command and see the output:

$ pactl info

… Server Name: PulseAudio (on PipeWire 0.3.32) …

https://wiki.archlinux.org/title/Pipewire#PulseAudio_clients

:ok: