Pipewire broke after I used my Windows VM and I can't figure out why


After my second reboot the issue suddenly fixed itself. I’m still keeping this post up though as it would be nice to know more about why this happened and perhaps how I can fix it if reboots don’t work. After all, it did require more than one reboot which is rarely a good sign.

Original post

Just a few minutes ago, I was doing musicians ear training in my Windows 10 VM installed in VMware with the app EarMaster Cloud. While I was working the audio suddenly started getting buggy so I decided to reboot my machine. After the reboot, I can’t seem to get a connection to PulseAudio (I’m assuming pipewire-pulse) with pavucontrol and if a program tries to play a sound it breaks.


I’ve tried restarting it with these commands and only get errors which I don’t understand. Everything is also installed on latest version

[runarcn@endeavour ~]$ sudo systemctl restart pipewire.service
Failed to restart pipewire.service: Unit pipewire.service not found.
[runarcn@endeavour ~]$ sudo systemctl --user restart pipewire.service
Failed to connect to bus: No medium found
[runarcn@endeavour ~]$ pacman -Q pipewire pipewire-alsa pipewire-audio pipewire-jack pipewire-pulse
pipewire 1:0.3.70-1
pipewire-alsa 1:0.3.70-1
pipewire-audio 1:0.3.70-1
pipewire-jack 1:0.3.70-1
pipewire-pulse 1:0.3.70-1

I’ve never encountered this issue on this install and I don’t know how to go forward. Any and all help is greatly appreciated as I either need to have this fixed by tomorrow or reinstall my entire OS which I really don’t want to.

For managing a --user service you don’t need sudo.

Try the same without sudo and see if it helps.

As written in the update the issue fixed itself after two reboots, but running the command does successfully restart pipewire. I’ll remember it should I run into the same issue some time later. Thanks!

I also can’t seem to mark the issue solved without clicking “Solution” on a comment which I kinda don’t wanna do just in case it doesn’t fix the issue and someone finds this thread in the future.

1 Like

When this happens to me, it is usually fixed after log out and log in.
I typically notice this issue when booting after some package upgrade.

Which comment? :rofl:
That’s why you should have created a new post for the Update in the initial post :wink: .

A reboot or relogin is OK as a Solution for such cases. Future readers will have to read the posts anyway :person_shrugging: .


Great, thanks!

Also, a big thanks in general to both you two! I regularly see you reply whenever users need help and all the answers seems to be very insightful ^-^

I think many of us feel much safer using EndeavourOS when we have people like you in order community


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.