Picom with corner-radius in i3wm shows weird squares

Hi! I am not new to EndeavourOS but new to these forums. It’s been like 9 months since I started using this wonderful distro. But I guess finally after a period of 9 months, it finally gave birth to a very annoying bug. I decided to have some corner radius in picom and as soon as I configured it to do so, I noticed some weird black squares around the corners.

This is my config file!

I saw this repo and I kinda like the configs so I thought maybe I should try it, but the corner radius is messed up for me.

hei welcome at the forum and thanks for using the i3 setup!

I see that https://github.com/EvanKoe/dotfiles_2022 using a forked version of picom… what picopm build are you using?

1 Like

It came pre-installed with endeavour os so I think it’s the AUR one

1 Like

EndeavourOS comes with picom. For this to work you either need to use picom-git or if you want to use advanced features…one of these:
https://aur.archlinux.org/packages/picom-ibhagwan-git The script you linked uses this one.

The three above depending on what you are trying to accomplish may need this in ~/config/i3/config:
exec --no-startup-id picom --experimental-backends -f ( or -b) you need to figure out what is best for your use case.


Ok so I installed picom-ibhagwan-git and started it by using exec_always --no-startup-id picom -b --experimental-backends in the i3 config and it worked for me, there are no black square around the corners anymore. However, the line which indicates the current window is selected in i3, I want to remove it for both focused and unfocused windows because it makes it look ugly. Could you please tell me how can I achieve that? Or is there a way to make it round too?

1 Like

Post your i3 config.

Here, these are the configs that I am currently using.

1 Like

Change this:

#border indicator on windows:
new_window pixel 1

# thin borders
# hide_edge_borders both

To this:

#border indicator on windows:
new_window pixel 0

# thin borders
 hide_edge_borders both

You can also experiment with this:
for_window [class="^.*"] border pixel 0

You are not using default EndeavourOS configs so you may have to play around a bit.

Thanks A Lottt!! The for_window [class="^.*"] border pixel 0 works for me but I just changed the wallpaper and noticed for some reason my i3bar has rounded corners, I think I excluded it the picom config but still it has some rounded corners.

1 Like

That is a new feature of picom and i3. i am not sure how to disable it. Give this a try:


corner-radius = 10
corner-radius-exclude = [
    "window_type = 'dock'"
# Dim inactive windows. (0.0 - 1.0)
# inactive-dim = 0.2;
# Do not let dimness adjust based on window opacity.
# inactive-dim-fixed = true;
# Blur background of transparent windows. Bad performance with X Render backend. GLX backend is preferred.
# blur-background = true;
# Blur background of opaque windows with transparent frames as well.
# blur-background-frame = true;
# Do not let blur radius adjust based on window opacity.
blur-background-fixed = false;
blur-background-exclude = [
      "window_type = 'dock'",
      "window_type = 'desktop'"


I am not at a linux box at the moment.

Nope. Not working​:sweat_smile:

Well at least we fixed the first two issues. Make a new post with this last one and see if others have a workaround. If it bothers you that much you could always make the dock transparent.

1 Like

I guess you’re right. Thanks for your precious time <3

1 Like

last try then you really should make a new thread lol…

# Exclude conditions for rounded corners.
rounded-corners-exclude = [
  "window_type = 'dock'",
  "window_type = 'desktop'"

I rounded my lxqt with openbox… that black squares are shadows… i made the shadows to 0 in my case in config file of mine…

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.