Picom-jonaburg-git Gives "Failed to get GLX context" error

Hello everyone , today i was trying to customise my XFCE4 desktop and was unable to load picom and gives the following error:-

[ 05/12/22 18:26:27.263 glx_init ERROR ] Failed to get GLX context.
[ 05/12/22 18:26:27.263 initialize_backend FATAL ERROR ] Failed to initialize backend

here is the result of picom --diagnostic

[ 05/12/22 18:28:30.098 parse_kawase_blur_strength INFO ] blur-strength: 4 [.iter = 2, .offset = 3.000000, .expand = 20]
[ 05/12/22 18:28:30.103 wid_set_text_prop ERROR ] Failed to make text property: vgit-e3c19.
[ 05/12/22 18:28:30.103 register_cm ERROR ] Failed to set COMPTON_VERSION.
**Version:** vgit-e3c19

### Extensions:

* Shape: Yes
* XRandR: Yes
* Present: Present

### Misc:

* Use Overlay: Yes* Config file used: /home/jaiyesh/.config/picom/picom.conf

### Drivers (inaccurate):

Intel

PLease help!!!

Seems a bit similar to this issue:

Does the picom in the official repo work?