Persistent Dota 2 Stutters on EndeavourOS (RTX 4070 Ti, i7-14700K) - Help Needed!

Hi everyone,

I’m hoping for some assistance with persistent Dota 2 stutters on my EndeavourOS machine, even after trying various troubleshooting steps. This issue has been plaguing me for a while, as I previously experienced similar stutters on older hardware, but I attributed them to aging components. Unfortunately, the problem persists even with my brand-new and significantly more powerful rig:

System Specs:

OS: EndeavourOS x86_64
Kernel: 6.6.10-arch1-1
DE: KDE Plasma 5.27.10
WM: KWin (X11)
CPU: Intel(R) Core(TM) i7-14700K @ 5.50 GHz
GPU 1: Intel UHD Graphics 770
GPU 2: NVIDIA GeForce RTX 4070 Ti
Memory: 31.11 GiB
Disk: 896.31 GiB (btrfs)
Terminal: kitty 0.31.0

The Problem:

Constant stutters in Dota 2, particularly noticeable during camera movement and random frame drops, fluctuating between ~120 and ~70 FPS.

Crucial point: This issue does not occur on Windows, where Dota 2 runs flawlessly with smooth FPS.

Native vs. Proton Games: Interestingly, other games like Apex Legends, Hitman 3, and Dying Light running through Proton work perfectly without any stutters. This suggests the issue might be specific to native games like Dota 2 and CS:GO2 (which also exhibits similar stutters).

Troubleshooting Steps Tried:

  1. Disabled shader caching
  2. Tried both OpenGL and Vulkan renderer
  3. Used Gamemode
  4. Switched from nvidia-dkms to nvidia drivers
  5. Tinkered with Steam launch options
    gamemoderun %command% -vulkan -novid -nojoy -novr -vulkan_disable_steam_shader_cache -vulkan_disable_graphics_pipeline_library -console
  6. Disabled Vsync and Gsync (Software and monitor settings both)
  7. Reinstalled GPU drivers (NVIDIA Driver Version: 545.29.06) nvidia-inst
  8. Adjusted power settings to performance
  9. Toggled “allow apps to block composting” in compositor settings
  10. Tried Wayland and X11 (both have stutters)
  11. Experimented with various in-game settings (fullscreen, windowed, etc.)
  12. Tested with only one monitor

observations :

  1. The problem seems to persist in native games only whole proton games run just fine
  2. vsync helps just a little in reducing the stutters
  3. nvidia-smi shows the Dota2 process in the processes list so it is running on dGpu
  4. The problem most probably is not due to the dual monitor setup as I tried with one monitor only
  5. Tried wayland much worse in terms of performance and stutters

Request for Help:

I’m at a loss and would truly appreciate any insights or suggestions! Please feel free to ask for any additional information or logs that might be helpful in diagnosing the problem. I’m open to any potential solutions, including potential compatibility issues, resource allocation, system configurations, or anything else that might be causing these stutters in native games like Dota 2.

Thanks in advance for your time and expertise!

i have also created several posts on Reddit regarding this problem and tried various methods mentioned there but the problem still persists

Post 1 in endeavour OS unofficial subreddit

Post 2 in linux_gaming subreddit

Hashtags:

#LinuxGaming #Dota2 #ProtonDB #EndeavourOS #GamingHelp

I can only say I need VSync in order to be able to play the game without stutters. Proton should not be used in my experience. Also OpenGL is not supported anymore by Dota2, afaik. Some launch options made things worse for me.

I have the feeling native Valve games simply don’t work too well sometimes, be it on NVIDIA or AMD. It’s pretty annoying and I asked around some months ago which yielded pretty much the same results as your research.

I would try to open a ticket inside the Dota2 bug tracker or look around in there if other people had similar problems.

1 Like

Thanks @I0F can you please share the reference to ticket here as well please it would mean a lot

Some (Proton) games for me have some weird frame drops as well, limiting the max fps to e.g. 60 solves the issue. Not ideal, but slightly lower fps is better than stutters imo. (Don’t know if Dota allows to set a limit though.)

Thanks for the reply @TheRaOct

dota2 has a native version so I’m not running it via Proton and Dota2 doesn’t connect to servers even if I try to run it with Proton

still, I tried as you suggested capping the max fps to 60/75/90/120 Fps there were very minor improvements and stutters were still there

Have you tried the zen kernel? Usually it doesn’t do that much, but who knows?

Oh and one more question: Are you running in fullscreen or windowed fullscreen? Had some games that had really poor performance in anything other than fullscreen

Tried all the options in fullscreen/windowed/desktop-friendly-fullscreen all of them had stutters

will do , i hope it works

@TheRaOct

The zen kernel did the trick now the stutter in almost negligible very close to smooth it is playable now

Thanks a Ton

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.