PDF Readers and Segmentation fault on XFCE

Hi,

If i try to open some of my pdf files, and work with them (i.e. scroll, jump to next page) my readers freeze-crashing.
I have xreader and xournal++ installed, and XFCE.

Error: Segmentation fault (core dumped).

Any help, guys?

1 Like

In order for the community to help you further, you can post a log in which the error occurs.

I have xournal++ errorlog
errorlog.20220706-164051.pdf (15.4 KB)

You said it happens with some PDF files, do those problematic files open in Firefox? just to rule out it isn’t the file.

Yes, i can open these files with firefox, and work with them. Those pdf’s are dictionaries (~185 MiB, and 55 MiB).

I had problems with xreader as well. Give atril a look.

xreader was recently updated to 3.4.1-1.

Is this system fully up-to-date?

I’ve installed atril and it also crashes :frowning:

xreader:

xreader: ../cairo/src/cairo-error.c:68: _cairo_error: Assertion `_cairo_status_is_error (status)' failed.
Aborted (core dumped)

atril

atril: ../cairo/src/cairo-error.c:68: _cairo_error: Assertion `_cairo_status_is_error (status)' failed.
Aborted (core dumped)

I updated the system.

Since the cairo package hasn’t been updated since 4/5, it’s hard to imagine that it’s all-of-a-sudden causing these crashes. I did find a recent thread on the Arch forums:
https://bbs.archlinux.org/viewtopic.php?id=277076

Like you, some, but not all, PDF files are causing xreader to crash while I navigate the document. I resolved my problem by downgrading to poppler 22.05.0-2 and poppler-glib 22.05.0-2:

sudo downgrade poppler poppler-glib

2 Likes

It looks like this solved the issue.

1 Like

There are these in the testing repo:

poppler: 22.07.0-1
poppler-glib: 22.07.0-1

They might have a fix for this issue. I haven’t though looked into it any further.

2 Likes

I just installed poppler 22.07.0-1 and poppler-glib 22.07.0-1 from the testing repo, and they do indeed seem to have fixed this issue.

1 Like

That’s great!
I never noticed the issue perhaps because I had updated the system to testing. Not something I do often, but occasionally.

So yes, I can confirm: PDF Readers are working great with old (22.05.0-2), and with test. vers. (22.07.0-1) of popper.

Hmm. I would like to have a stable system with working applications, but everytime something is broken on my XFCE (catfish, flowblade, now readers). Is this ok for linux? Maybe i should try non-arch based distro? Or other DE (i.e. KDE)?

While your issue has been solved, you can now mark the corrsesponding post as “solution” to this thread.

For other issues you might have, please open new threads, @uwasan .

:checkered_flag:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.