Pcmanfm-qt - disable desktop manager

How can I prevent pcmanfm-qt from starting desktop manager on login? Should I just put exec pcmanfm-qt --desktop-off into my wm’s config or there’s a better way to do it?

It should be called “Desktop” in lxqt’s “Session Settings”. You can disable it there. Keep in mind, that will take away your icons, background and lxqt’s desktop right click context menu.

Alternatively, if you just want to get the default icons off the desktop, that can be done in the Desktop Settings on the Advanced tab.

It worked, thank you.

1 Like