pCloud GUI Fails to Launch in KDE Plasma

I’m really not sure why, but after downloading the “pcloud-drive” package from AUR, things were working as expected for a day or two.

However, now when I launch it, it launches in the background, with no GUI nor tray icon. I actually didn’t notice this until I temporarily lost my Wi-Fi connection and received a notification from pCloud that there was no internet connection. Shortly after, the icon showed up.

Been dealing with this for a few days now. I’m having to disable my Wi-Fi before launching pcloud, then reenable it just to get the GUI, but the GUI says everything uploaded/downloaded, which as you can see in KSysguard, is not the case.

Does anyone know why this is happening or what I can do to fix it?

[User@Device ~]$ neofetch
                     ./o.                  User@Device 
                   ./sssso-                ---------------- 
                 `:osssssss+-              OS: EndeavourOS Linux x86_64 
               `:+sssssssssso/.            Host: 20HKCTO1WW ThinkPad P71 
             `-/ossssssssssssso/.          Kernel: 5.17.1-arch1-1 
           `-/+sssssssssssssssso+:`        Uptime: 2 hours, 7 mins 
         `-:/+sssssssssssssssssso+/.       Packages: 1464 (pacman) 
       `.://osssssssssssssssssssso++-      Shell: bash 5.1.16 
      .://+ssssssssssssssssssssssso++:     Resolution: 1920x1080 
    .:///ossssssssssssssssssssssssso++:    DE: Plasma 5.24.4 
  `:////ssssssssssssssssssssssssssso+++.   WM: KWin 
`-////+ssssssssssssssssssssssssssso++++-   Theme: [Plasma], Qogir-dark [GTK2/3] 
 `..-+oosssssssssssssssssssssssso+++++/`   Icons: [Plasma], breeze-dark [GTK2/3] 
   ./++++++++++++++++++++++++++++++/:.     Terminal: konsole 
  `:::::::::::::::::::::::::------``       Terminal Font: Liberation Mono 8 
                                           CPU: Intel i7-7700HQ (8) @ 3.800GHz 
                                           GPU: NVIDIA Quadro P3000 Mobile 
                                           Memory: 3877MiB / 15800MiB


Update: I decided to download the app directly from pCloud. At first, it still recognized my device as the same, so it still didn’t launch the GUI. So, I deleted the “.pcloud” folder in the Home directory as well as the “home/.config/pcloud” folder.

Now the GUI has launched from the start, but I now have to wait FOR AGES for everything to verify as already synced.

This is by no means a solution… As such, I have only moved the previous config folders to another area, just in case I run into the same issue after I restart my system a few times. Will update this post on whether this work-around works or not.

Hi
I use the app downloaded from the pcloud website. I also noticed this morning that pcloud had no internet connection and yet I was well connected (wired) and everything worked fine.
I don’t know why either!
Remain to wait for an update I think.

That’s weird. Does it show internet activity in your system monitor app?

I hope it’s fixed soon because it’s annoying not knowing if my files are really being synced or not.

Hello
This morning no problem, pcloud connects perfectly.

Same here! Maybe this is one of those cases where the original app is better than the AUR.

Hopefully, the mods don’t close this thread too early, as I want to do a few more restarts and updates to ensure that using the AppImage provided directly by pCloud is the solution. Will give it until Wednesday.

Okay. So, I think it’s safe to say that using the AppImage provided by pCloud themselves is currently better than installing from AUR.

Due to updates, I’ve restarted my system at least 6 times in the last 3 days and so far the pCloud GUI launches properly every time.

This of course means the AUR package isn’t fixed and needs to be.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.