PC wakes up immediately after suspension

  • Kernel: 5.19.5-arch1-1
  • DE: GNOME on Wayland (42.4)
  • PC Specs
    • Motherboard: Gigabyte Z97P-D3
    • CPU: Intel i7-4790
    • RAM: 16GB + 8GB Swap
    • GPU: Gigabyte AMD Radeon RX 6600 (switched recently from an ASUS GTX 1060)
    • PSU: Corsair CX750M 750W (switched recently from a generic Corsair 600W)

Issue explanation

PC shuts down normally and stays shut on first boot.

If I enter sleep mode by idling or clicking on suspend from the topbar my PC goes to sleep then it starts up immediately after.
After that every time I shut down my PC it reboots like it was waking up from sleep.
Even shutting down on the vendor screen before GRUB at this point reboots the PC.

If I do not enter sleep mode and just shut down the PC it stays shut.

Disconnecting the power supply before it reboots resets this behavior until the PC enters sleep mode again.

It started doing this after I switched my PSU and GPU.

Troubleshooting that I have already done

  • Unplugging all USB devices from the PC, no change
  • Following this section from the Arch Wiki, no change
    • I can’t disable PXSX from /proc/acpi/wakeup but I don’t think it’s related to this issue
  • Disabling everything that can wake the PC in the BIOS, no change
  • Following this other section from the Arch Wiki, no change
  • Checked for obvious errors in journalctl and dmesg, found nothing other than
    • ACPI BIOS Error (bug): Could not resolve symbol [\_GPE._L09.D1F0], AE_NOT_FOUND (20211217/psargs-330)
    • That brought me to this topic that said they could be ignored
    • was able to disable this error by adding acpi_mask_gpe=0x09 as a kernel argument
  • Did a clean install (maybe a package I installed caused the issue), no change
  • Removed all PCI cards from my PC
    • Found out when removing the GPU the issue went away
  • Tried adding the kernel argument amdgpu.runpm=0 (from this article), no change
  • Disabling PEG0 and PEGP from /proc/acpi/wakeup didn’t solve the issue as well (they weren’t there when the GPU wasn’t plugged in)

journalctl log of the issue

What can I do to solve this issue?

Solved the issue, apparently it was my DisplayPort Cable that caused the issue

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.