Password Prompt on Login for mounting drives

Hello everyone! I am loving Endeavour OS. I think I’ve finally found my home. Suffice to say I learnt to yay, nay and sway without exploding my computer. So that’s a step forward! Still an infinite way to go.

In summary, my issue is: After each login, I get prompted to put in a password for drives. The first one is the SSD where the OS is in, and later if I go into Dolphin (I am using KDE), I have to click on the HDD to mount it, on which I also get prompted for a password. All mounting goes fine, so there’s no issue with that.
And to be clear just in case, I want to have everything to automount and without a password. I understand the thing about security, but I am the only one who uses this PC. And having to input a password/having them unmounted breaks functionality when I choose to use the storage drive. Considering the first prompt is for the SSD, I could use the workaround of setting everything to download into /home and then cut and paste it into the HDD manually, but it’s a hassle after a while and still would require my manual input of the password.

I am dual booting with Windows 10 on the SSD. And I generally use the HDD for files but I made a /home partition just in case because you never know.

This is how my fstab looks like now.

And this is how my blkid looks like.

I’ve been researching a bit, trying to avoid make yet another post about it which I know many people ask and have asked all the time, but I still have some doubts sadly. I’ve read some posts, watched Chris Titus’ and TechHut’s video on how to automount, read the man fstab page to understand a bit better each section, etc.
I also came across this post which left me with some more doubts since I wasn’t sure what OP was trying to do, generally speaking, although the beginning of the post is my exact issue. (This is a good thing since I was going to change values in fstab to see if that would do the trick, but I am afraid that could break the boot).
Coming from Manjaro, my first try was the one RickLinux showed in said post which I knew and had used, the KDE option for automount removable devices. However that didn’t work.

As you could see on the screenshots, fstab doesn’t have the HDD listed (It’s the drive labeled “Storage”).
On the forum post linked before, Dalto also mentioned something about polkit permissions. Considering these 2 things I assume I would have to do the automount through fstab first and then do the polkit thing. Is that correct?
If that is the case, I understood / can follow the steps for the fstab mounting (although I’d like to know if setting the HDD as 0 2 values would be correct instead of 0 0; so I know if I understood the man page correctly) but I have no idea how to access the polkit file (it’s inside a locked folder) and wouldn’t what to put in it nor where.

From now, thanks in advance. And let me know if there’s more info you may need, apologies if I missed anything.

Edit: formatted better. Didn’t know — under a line made it mega big and bold, lol.

Personally I’ve always used gnome-disk-utility to setup auto-mounting of my drives and have never experienced what you described.

Just in case you haven’t tried that yourself before, here are the steps I take;

In Gnome Disks, select the drive, click “additional options” then “edit mount options”. Next toggle off “use session defaults” and make sure “require additional authorization” is disabled.


Worked like a charm!
I saw that solution here and there, but some people said it didn’t work for them (can’t know if it was user error) and I was also afraid that being a GUI solution might’ve not been persistent while maybe modifying something and breaking, so then you’d have to fix that, and then do the whole other thing.
Clearly I was wrong. Marked as solution, thank you mate!

1 Like

I’ve had this issue before on an internal second drive. Usually happens after switching distros. Most likely a permissions issue. Expecting it to be my fault, but I might have figured it out because it didn’t happen with EndeavourOS this time around.

1 Like

I think it is something with permissions, but due to the fact that these partitions/drives are NTFS, at least what I understood from some things I’ve read. The Storage HDD was formatted on Windows as that’s where I started using it. Same thing for the “basic file partition” which in reality is where Windows sits.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.