Password not working?

Hii, so I’ve had this issue back on manjaro as well- sometimes, the computer refuses to take my password whether it’s for using sudo or for simply logging in. I know for a fact that I did not misspell it and that the caps lock was not on. I just got it after a reboot and the only way around it at the time was to reboot again, after which the issue resolved. Since it can be resolved like that it’s no biggie but it is mildly annoying.

Is this a known issue with arch distros, and is there anything I can do to stop it from happening? I’ve never had this problem on my debian and debian-based systems.

Thanks for reading!

Hi there. I had same symptoms in the past, but I think it was because I used an nvidiafan script, which I removed since.

can you post the output of this:
sudo faillock

alternatively, if it doesn’t let you to call for this, due to lockout, then do a su - and enter root

then issue the command above once again, dont forget to exit from the root enviroment, before closing the terminal afterwards.

do you have any automatizated scripts?

have you customized your sudoers file via sudo visudo lately, or is it untouched?

~ Magus

1 Like

Hi, thanks for the reply!

Doing sudo faillock gives me this:

When Type Source Valid

There’s not an issue currently as I fixed it with a restart. I don’t believe I have any automised scripts- at least I didn’t enable any and I’m too much of a noob to know how to check whether any are running without my knowledge (or really to know what they are either in the specifics tbph). I’ve never customised my sudoers with that command, this OS is also like three days old lol

Let’s look at your journals, to troubleshoot.

Steps to share the journal log:

  1. Open a terminal and type: eos-log-tool -j
  2. Leave everything as it is, and additionally tick 2nd and 3rd most recent journals.
  3. Click on share logs, and u get a link afterwards, paste the link here

~ Magus :mage: :magic_wand:

No. It is not. This should not happen.

Does your password contain special characters which need a special keymap (e.g. german umlaute äöüÄÖÜ) ?

Do you have any scripts / services which change the keymap? Anything in your ~/.bashrc?

Which DE resp. Login Manager are you using? gdm/gnome, sddm/plasma, etc.

Show us the output of “fastfetch” command

Strange that it’s so far been a consistent issue with my arch based systems. This isn’t even on the same hardware.

my password does not have any Umlaute or anything, just numbers and normal Latin alphabet letters you find in English. I do not have any scripts or services that change the keymap, I just picked the layout for the keyboard I have at setup. Nothing in ~/.bashrc. I’m using KDE plasma 6.

Fastfetch tells me “command not found”

Will there be any sensitive information like IP addresses in those journals?

I’ve only ever used them once on debian in a pitiful attempt to figure out how to revive my nvidia drivers, but couldn’t do anything with them ultimately and don’t remember much about them

As far as I can tell, no IP address will be shown in the journal, however the network card’s physical MAC address will be revealed, which makes you identifiable.

If this is a problem to you, then don’t share it, but then it is mostly impossible for us to diagnose what the problem source really is, aka, it’s gonna be a guessing game then.

Also these links have a lifetime of 1 week (currently only 0x0 supported) by default, but you can make it shorter, for this you gotta use the terminal.

Also you can always manually extract the journals, filter out your sensitive datas (its gonna take a while lol), and then send it if you want.

You can always share this instead: inxi -Fxxc0z | eos-sendlogthis filters out most of the sensitive dataz

More details here:
https://discovery.endeavouros.com/forum-log-tool-options/how-to-include-systemlogs-in-your-post/2021/03/

Happy Linuxing :slight_smile:

~ Magus :mage: :crystal_ball: