Password not accepted?

Suddenly my password is not being accepted. I’ve checked my password and made sure it’s correct. Only thing I did was a yay update and rebooted. Any help??

I have faced this in the past.

The easiest sure shot fix I found was to chroot into my installation and run passwd <username>.

I am able to log in fine if I choose GNOME as the DE. i3 doesn’t give an error about the password, it actually looks like it tried to load the DE but goes right back to the login screen

Then probably i3 isn’t able to start. Did you change the configs?

@joekamprad This looks like an i3 problem.

Check the permissions on your home directory first.

Is there any chance you accidentally used sudo to make changes to your config or ran a graphical program as root?

It is normally safe to reset the ownership of files in home directory unless you are doing something exotic.

sudo chown username:username /home/username

Replace all the usernames with your actual username.

If that isn’t it, I would try backing up and replacing your i3 config with default config.

1 Like

I hit something similar a little while ago. Not generally an i3 user, but I have an EOS install with it set up. After an update, I started getting similar - Lightdm would come up, enter my password, back to lightdm.

I had a look at the journal, and found Xorg was dumping core and restarting. Having had a similar problem on another laptop, I uninstalled xf86-video-intel. Which fixed the problem - i3 is starting again now.

Oddly enough, on the same laptop, I’ve got a pure Arch install with Xfce. It still has xf86-video-intel installed and has had no problems…

So if the machine has intel video, it may be worth trying the same trick.

you put EOS i3 on different user than eos gnome or same usr?

aslo you did this as @joekamprad state ?

Warning: if you install EndeavourOS-i3 aside with a full DE (XFCE4, GNOME, Plasma e.t.c.)

you need to comment out dex starter from ~/.config/i3/config file !!!

#exec --no-startup-id dex -a -s /etc/xdg/autostart/:~/.config/autostart/
ode here

from here

Edit… maybe check what update via yay

1 Like

Have you checked the pacman logs or arch news after the last updates?

1 Like

Solved. I made a change to xorg last night to try and enable natural scrolling. Left the system powered off and then tried to power on this morning post chage, no go. Removed the suggested edit to the config file and also chown the home dir, all is fixed.

Still have no natural scrolling and also found out that only gdm works - lightdm causes a very ugly screen render. Luckily I had GNOME installed (not sure how, I don’t recall selecting it during install… but that saved me a ton - allowed me to edit the config and reboot back to i3 just fine.


my fault … :pray: it was only idea :+1: glad you fix

Edit …if you copy and paste z edit i posted xorg get stuck ( artifacts added ) if type out posted edit no problem starting … i just test it boot no problem

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.