Pamac (Package manger) slow download

Hi All,

I hope this the right thread, recently installed endeavour and got everything mostly working I wanted ask why is pamac slow when downloading ?

Make sure to setup your mirrors correctly.

You can do that manually, by editing /etc/pacman.d/mirrorlist, or…

Since you’re using Pamac, I’ll assume you came here from Manjaro, and then you probably know about the Manjaro script pacman-mirrors that automatically configures your mirror list. Here, you can use a similar tool, called reflector. EndeavourOS gives you a nice GUI frontend for it called reflector-simple.

For more info, see:
https://endeavouros.com/docs/pacman/mirrors-for-pacman/
https://endeavouros.com/docs/pacman/rank-mirrorlist/
https://wiki.archlinux.org/index.php/Mirrors
https://wiki.archlinux.org/index.php/Reflector

TL;DR:
Run reflector-simple, select the mirrors you want, and rank them by speed, click OK, wait a minute or so for the tool to do its magic, and save the list (you will be prompted for your sudo password). Now, packages should download much faster.

6 Likes

You’ve reached the maximum number of likes. Please wait 1 hour before trying again.

2 Likes

^ If I ever decide to write an autobiography, that would be its title.

You’ve reached the maximum number of likes. Please wait 57 minutes before trying again.

1 Like

Interesting. Who’d it be about?

1 Like

I’m abit of noobish with this stuff I did a clean install to see how it we’ll it works for me as a daily driver.

Did you read & do per here?

It’s good advice. Just ignore the Manjaro parts now that you mentioned it was a clean install.

2 Likes

Everyone is a noob at some point, I’m still one :slight_smile: Feel free to ask if anything is unclear.

@anon379864: it would be about frogs. :frog:

1 Like

You’ve reached the maximum number of likes. Please wait 46 minutes before trying again.

1 Like

I’ll get back to you once I’m done with work also many thanks for the reply.

1 Like

@ImpactKaizer
In the preferences make sure concurrent downloads is set to 0. That’s what I do and it’s fast!

1 Like

Got it working thanks for the help.

4 Likes

To clarify, Rate is speed :grin:

2 Likes

Kinda figured that after messing with software :grin:

But I’m curious how dose this work in the terminal ?

Magic :smiley: :wink: :slight_smile:

2 Likes