Pamac-aur takes long to check for updates

Greetings lovely community,

I’ve had this issue for about two days now. Didn’t think too much of it initially, but I wanted to see if anyone else was having a similar issue or if it was somehow just me experiencing the issue. I’m using pamac-aur --version 10.1.3-1, and when I use the tab to check Updates, normally it would return results in about 10-15 seconds. However, for the last two or so days, it takes about a minute to a minute and a half to check for updates before results are finally displayed. A similar thing happens when I run pamac checkupdates from the terminal and it takes about a minute before results are displayed.

My internet is fiber 1GB, though I am on wifi so my speeds typically range around ~150MBps, which is more than enough. I’m not downloading, uploading, or seeding anything so I don’t believe it has anything to do with my connection. I’m assuming it may be the result of some recent updates perhaps, but I’m not too sure (looks at iproute2 with curious eyes). I haven’t found anyone else mention this issue before, so it could be just me.

A curious quick glance over at the Manjaro forums (since they develop Pamac) shows from their recent updates there were a few users with some Pamac issues, but nothing that I could track down that was quite related to what I am experiencing.

When updating, pamac-aur will hover at 90% on this screen for about a minute before results finally show up. Normally in the past this should take only about 10 seconds.

Curiously enough, when I run checkupdates I get results almost instantly. However when I run pamac checkupdates it once again takes about a minute before results appear.

I don’t know if it matters at all, but sometimes when updating, I have System Monitor open and I’ll see the process makepkg spikes the CPU for a brief moment, but I assume that’s probably normal behavior.

Here’s just the most recent updated packages I did in case anything strikes someone’s eyes. I don’t know if any of the recent package updates could be the culprit or not, but figured it couldn’t hurt to post this as well.

Output for grep -i upgraded /var/log/pacman.log from the last couple of days below:

[2021-08-28T16:16:58-0500] [ALPM] upgraded cups-filters (1.28.9-1 -> 1.28.10-1)
[2021-08-28T16:16:58-0500] [ALPM] upgraded eos-apps-info (1.0.4-1 -> 1.0.6-1)
[2021-08-28T16:16:58-0500] [ALPM] upgraded eos-log-tool (1.4.8-1 -> 1.4.8-2)
[2021-08-28T16:16:58-0500] [ALPM] upgraded geoip-database (20210727-1 -> 20210824-1)
[2021-08-28T16:16:58-0500] [ALPM] upgraded glslang (11.5.0-1 -> 11.6.0-1)
[2021-08-28T16:16:58-0500] [ALPM] upgraded shaderc (2021.1-1 -> 2021.1-2)
[2021-08-28T16:16:58-0500] [ALPM] upgraded libplacebo (3.120.3-2 -> 3.120.3-3)
[2021-08-28T16:17:00-0500] [ALPM] upgraded linux-lts (5.10.60-1 -> 5.10.61-1)
[2021-08-28T16:17:03-0500] [ALPM] upgraded linux-lts-headers (5.10.60-1 -> 5.10.61-1)
[2021-08-28T16:17:03-0500] [ALPM] upgraded python-google-api-python-client (2.17.0-1 -> 2.18.0-1)
[2021-08-28T16:17:03-0500] [ALPM] upgraded python-kiwisolver (1.3.1-3 -> 1.3.2-1)
[2021-08-28T16:17:04-0500] [ALPM] upgraded xorg-xrdb (1.2.0-2 -> 1.2.1-1)
[2021-08-28T16:22:22-0500] [ALPM] upgraded bitwarden (1.28.1-1 -> 1.28.2-1)
[2021-08-28T16:22:28-0500] [ALPM] upgraded gwe (0.15.3-1 -> 0.15.4-1)
[2021-08-28T16:28:20-0500] [ALPM] upgraded popsicle-git (1.3.0.r43.g1a94779-1 -> 1.3.0.r44.gda43ab9-1)
[2021-08-28T19:04:45-0500] [ALPM] upgraded glances (3.2.1-1 -> 3.2.2-1)
[2021-08-28T19:04:45-0500] [ALPM] upgraded glib-networking (1:2.68.1-1 -> 1:2.68.2-1)
[2021-08-29T17:24:39-0500] [ALPM] upgraded qemu (6.0.0-3 -> 6.1.0-1)
[2021-08-30T10:43:32-0500] [ALPM] upgraded eos-bash-shared (1.9.8-1 -> 1.9.9-2)
[2021-08-30T21:50:06-0500] [ALPM] upgraded dkms (2.8.4-1 -> 2.8.5-1)
[2021-08-30T21:50:06-0500] [ALPM] upgraded imagemagick (7.1.0.4-2 -> 7.1.0.5-1)
[2021-08-30T21:50:06-0500] [ALPM] upgraded qt5-base (5.15.2+kde+r215-2 -> 5.15.2+kde+r222-1)
[2021-08-30T21:50:07-0500] [ALPM] upgraded qt5-declarative (5.15.2+kde+r29-1 -> 5.15.2+kde+r30-1)
[2021-08-31T10:54:46-0500] [ALPM] upgraded libgcrypt (1.9.3-1 -> 1.9.4-1)
[2021-08-31T10:54:46-0500] [ALPM] upgraded man-pages (5.12-2 -> 5.13-1)
[2021-08-31T10:54:46-0500] [ALPM] upgraded systemd-libs (249.3-1 -> 249.4-1)
[2021-08-31T10:54:46-0500] [ALPM] upgraded systemd (249.3-1 -> 249.4-1)
[2021-08-31T10:54:46-0500] [ALPM] upgraded systemd-sysvcompat (249.3-1 -> 249.4-1)
[2021-08-31T10:56:24-0500] [ALPM] upgraded timeshift (20.11.1+4+gd437358-1 -> 20.11.1+4+gd437358-3)
[2021-09-01T13:35:06-0500] [ALPM] upgraded aom (3.1.2-1 -> 3.1.2-2)
[2021-09-01T13:35:06-0500] [ALPM] upgraded avahi (0.8+20+gd1e71b3-1 -> 0.8+22+gfd482a7-1)
[2021-09-01T13:35:06-0500] [ALPM] upgraded freetype2 (2.10.4-1 -> 2.11.0-3)
[2021-09-01T13:35:07-0500] [ALPM] upgraded electron11 (11.4.12-1 -> 11.5.0-1)
[2021-09-01T13:35:07-0500] [ALPM] upgraded python-typing_extensions (3.10.0.0-1 -> 3.10.0.2-1)
[2021-09-01T13:35:07-0500] [ALPM] upgraded telegram-desktop (2.9.3-1 -> 3.0.0-1)
[2021-09-01T20:27:56-0500] [ALPM] upgraded re2 (1:20210801-1 -> 1:20210901-1)
[2021-09-02T04:51:20-0500] [ALPM] upgraded tzdata (2021a-1 -> 2021a-2)
[2021-09-02T04:51:20-0500] [ALPM] upgraded gpm (1.20.7.r38.ge82d1a6-3 -> 1.20.7.r38.ge82d1a6-4)
[2021-09-02T04:51:20-0500] [ALPM] upgraded iproute2 (5.13.0-1 -> 5.14.0-1)
[2021-09-02T04:51:26-0500] [ALPM] upgraded papirus-icon-theme (20210802-2 -> 20210901-1)

If it’s relevant at all, here is my output for grep -i installed /var/log/pacman.log below for some of my most recently installed packages from the last couple of days:

[2021-08-12T22:41:11-0400] [ALPM] installed gwe (0.15.3-1)
[2021-08-16T14:43:12-0400] [ALPM] installed dracula-gtk-theme (v2.0-1)
[2021-08-16T17:24:21-0400] [ALPM] installed gtk-engine-murrine (0.98.2-4)
[2021-08-16T20:48:31-0400] [ALPM] installed yaru-sound-theme (21.10.1-1)
[2021-08-16T20:58:07-0400] [ALPM] installed yaru-gnome-shell-theme (21.10.1-1)
[2021-08-16T20:58:07-0400] [ALPM] installed yaru-session (21.10.1-1)
[2021-08-16T20:59:26-0400] [ALPM] installed libxpresent (1.0.0-2)
[2021-08-16T20:59:26-0400] [ALPM] installed metacity (3.40.0-1)
[2021-08-16T21:00:01-0400] [ALPM] installed yaru-metacity-theme (21.10.1-1)
[2021-08-16T21:01:43-0400] [ALPM] installed humanity-icon-theme (0.6.15-1)
[2021-08-16T21:02:11-0400] [ALPM] installed yaru-icon-theme (21.10.1-1)
[2021-08-16T21:03:22-0400] [ALPM] installed yaru-gtksourceview-theme (21.10.1-1)
[2021-08-16T21:04:28-0400] [ALPM] installed yaru-gtk-theme (21.10.1-1)
[2021-08-22T04:49:53-0500] [ALPM] warning: /etc/pacman.d/mirrorlist installed as /etc/pacman.d/mirrorlist.pacnew
[2021-08-27T10:24:28-0500] [ALPM] installed eos-apps-info (1.0.4-1)
[2021-08-29T17:24:39-0500] [ALPM] installed libbpf (0.4.0-1)
[2021-08-30T11:16:53-0500] [ALPM] installed exfatprogs (1.1.2-1)
[2021-08-31T10:54:46-0500] [ALPM] installed diffuse (0.6.0-1)
[2021-09-01T13:35:07-0500] [ALPM] installed rhythmbox (3.4.4-4)
[2021-09-01T13:42:47-0500] [ALPM] installed intltool (0.51.0-6)
[2021-09-01T13:42:47-0500] [ALPM] installed libkeybinder3 (0.3.2-3)
[2021-09-01T13:43:04-0500] [ALPM] installed rhythmbox-plugin-alternative-toolbar (0.19.3-1)
[2021-09-01T18:59:56-0500] [ALPM] installed yaru-metacity-theme-git (1:21.10.1.r33.ge5c308eda-1)
[2021-09-01T18:59:56-0500] [ALPM] installed yaru-unity-theme-git (1:21.10.1.r33.ge5c308eda-1)
[2021-09-01T18:59:56-0500] [ALPM] installed yaru-sound-theme-git (1:21.10.1.r33.ge5c308eda-1)
[2021-09-01T18:59:56-0500] [ALPM] installed yaru-gnome-shell-theme-git (1:21.10.1.r33.ge5c308eda-1)
[2021-09-01T18:59:56-0500] [ALPM] installed yaru-gtksourceview-theme-git (1:21.10.1.r33.ge5c308eda-1)
[2021-09-01T18:59:57-0500] [ALPM] installed yaru-icon-theme-git (1:21.10.1.r33.ge5c308eda-1)
[2021-09-01T18:59:57-0500] [ALPM] installed yaru-gtk-theme-git (1:21.10.1.r33.ge5c308eda-1)
[2021-09-01T18:59:57-0500] [ALPM] installed yaru-session-git (1:21.10.1.r33.ge5c308eda-1)

Finally, running pamac-manager from the terminal and running Check Updates didn’t produce any error messages in a terminal so I didn’t bother to post that output. I suppose for the moment I am at an impasse! Now I don’t know if maybe perhaps pamac needs some rebuilds for things to function properly or if like I said perhaps it is just an issue on my end somehow. In any case, any insight, advice, or help would be most appreciated and if anyone else is experiencing this issue as well please let me know, thank you!

Did you try to update your mirrors (e.g. using the eos welcome app)? Just checking the obvious first…

2 Likes

I tend to doubt it’s that easy - as checkupdates (the terminal equivalent) runs at normal speed…

Unfortunately I could never figure out pamac properly, so I learned pacman instead…

1 Like

Ah yes I forgot to mention two things, I did update my mirrors with simple-reflector and got no change unfortuntaely. I also tried using Pamac’s “Refresh databases” option, which took like over a minute to do that as well when it normally should also be rather quick, but also noticed no change. Still takes over a minute to get updates to show up.

To make sure that things are in sync (although I suspect the “refresh databases” option did this) try sudo pacman -Syy. This takes 10 seconds on my rig, and shouldn’t be more than 30 I would think.

More of a setting up the parameters than an expected cure though!

Edit: Did an upgrade for pamac happen recently?

1 Like

Last pamac-aur update was:

[2021-07-25T18:11:35-0400] [ALPM] installed pamac-aur (10.1.3-1)

But I didn’t experience this issue then, it has only been within the last 2 days or so and that update was from over a week ago. When I run sudo pacman -Syy it returns results almost instantly, which is a good sign at least I think.

I just did a fresh install and pamac-aur-git is doing the same. 90% and it just hangs for sometime.

1 Like

Thanks for taking the time to help to confirm the issue. Here, have some lovely steamed broccoli I just made :broccoli::slight_smile:

1 Like

I did send a message to the dev who looks after it.

1 Like

I’m using pamac-aur and you’ve just tested pamac-aur-git so looks like something is giving an issue to both of them that hasn’t been addressed/seen yet by the devs it looks like.

I remember there was some option in pamac to check for updates of -git packages. Something like “check for development package updates” or so.

That one can cause quite some slowdown if you have a couple of -git packages installed. (It will actually re-download sources for all those packages those -git packages each time you search for updates…)

1 Like

I’m not a dev, only the maintainer on AUR and bug reporter on pamac gitlab project page :smiley:

1 Like

Might not be related to your issue but when I have flatpak support enabled in pamac, I experience a certain slowdown in it loading up the packages and when searching for them.

1 Like

You know, now that you mention it, I did install 8 git packages from the AUR just the other day. From my post above about recently installed packages, I installed 8 Yaru related packages since I like the Ubuntu theme so much (normally I opt for Yaru-colors, but that’s not updated yet!), and that’s the best way to get the latest updated packages. Before using the git packages from the AUR, I was just building it myself each update, which was becoming a little bit tedious, but the AUR versions helped simplify that process for me, which is why I decided to install them all just very recently.

I went ahead and ran an update with my current Third Party pamac configuration and just like before it still took about a minute to show updates. Then I went back into the Third Party settings and turned off “Check for development packages updates” and lo and behold it showed updates almost instantly.

For reference, below is my pamac settings before I turned anything off.

So looks like you were right, thanks for bringing that to my attention, I wouldn’t have figured that out ever otherwise! I suppose that this would be more of a feature though than a bug, would you agree @moson? If that’s the case, which it may very well be, then there isn’t really anything to report as a bug if it is indeed functioning as intended. It is a bit unfortunate that updating one way is almost instant and updating the other way takes so long. I suppose I may end up turning off the “Check for development packages updates” setting unless I need it on, which would make pamac more useful to me. Having it take so long to update does defeat the usefulness that I currently have pamac installed for to being with.

@ricklinux If you can also test this out with the Third Party options all ON and updating and then turning off “check for development packages updates” and updating and see if you noticed any differences as well or not on your fresh install, I’d appreciate that. It probably helps to test this if you have a few git packages installed. On my system I’ve got 10 git packages from the AUR that I currently use.

@FredBezies You may not be a dev man, but you are the bug man! :stuck_out_tongue:

@pebcak I use pamac-aur, which doesn’t come with flatpak/snap support (i think that’s what pamac-all is for though), so I can’t speak on that. I did have a few flatpaks installed last month, but then realized they were all also available on the AUR as well, so I took the plunge and now I’m using a flatpak free system. Side note, I do like flatpaks, I just wanted a system done the Arch way or something like so that I could learn/experience more on the Arch side of things :slight_smile:

2 Likes

Right, sorry for overlooking that. :man_facepalming:t5:
I have pamac-all but with snap support disabled.

IAs a matter of fact, I have been thinking of doing the same. I have a few flatpaks installed. I should be looking to see if I find them in AUR.

No worries! I can always forgive a fellow Gnome user of course :wink:

As long as your flatpaks aren’t like mission critical applications that you need for say work, I’d say go for it and give some of the AUR versions a try, if they have any. I dove into the AUR because I wanted a better understanding, which I’m still doing and learning, and I didn’t want to be afraid of it (I always heard the AUR this/that beware comments online). As long as you understand something, then there’s no need to fear it!

1 Like

Go Gnomies Go! :partying_face:

No, they aren’t so I actually can be doing fine even without them as well.
I am also in the process of learning how PKGBUILDs work. I can figure out some of the more simple ones so I can see what they do but not those more complicated ones yet.

1 Like

Yeah. The problem with pamac implementation is that it will download the -git package sources each time to check if the package is still up-to-date. Thats quite a waste of resources and time.

Yay for example does in much more clever way. It stores the last git commit hash for each -git packages you install in some local file. Now when it checks those packages for updates it simply compares the stored hash against the latest commit hash in the source git repository. (If they match → nothing to update; if they don’t → rebuild and install package)

1 Like

Try running

yay -Qua

This will check for AUR updates. If it is fast, and checkupdates is fast, then it’s a problem with Pamac, which would be totally unsurprising, because there are always problems with Pamac. Only a masochist can enjoy using that piece of… well, my rant has stopped being productive, so I’ll shut up… :smiley:

2 Likes

There’s gotta be a better way to do that…

Oh, looks like there is a better way to do that after all! :stuck_out_tongue:

Thanks for taking the time to explain this, it makes a lot more sense now, so I do appreciate your help! I’m just gonna go ahead and keep the ‘check for devel pkg updates’ turned off in Pamac since I doubt they’ll change how they handle git updates any time soon. I’ll just have to rely on yay for all my updating needs I think!

@Kresimir Does yay have something like checkupdates or pamac checkupdates that just displays all available updates, but doesn’t download anything?

1 Like