Pamac-aur-git (9.5.6.r1.g88346f9-1): No system tray icon

For some reason, on one of my laptops over the last week or so, I have lost the pamac “shield” icon in my system tray and I’m not getting update notices. I’m guessing that a systemd service has failed to start, but I’m not sure what that service name might be to check status. Perhaps my diagnosis is wrong, too. I’d appreciate any help debugging this issue. Here’s what I have installed, and which worked properly until recently:

pacman -Q | grep pamac
pamac-aur-git 9.5.6.r1.g88346f9-1
pamac-aur-tray-appindicator-git 9.5.6.r1.g88346f9-1

Thanks in advance for any thoughts/ guidance!

Barry

Edit:
PS I have this same configuration on all my other machines, and they seem to be working correctly. Hmmmm :thinking:

Further to this question, when I run

systemctl status

I get the following (partial) output, which seems to include /usr/bin/pamac-tray-appindicator:

session-2.scope 
           │     ├─1175 lightdm --session-child 12 19
           │     ├─1193 /usr/bin/startplasma-x11
           │     ├─1247 /usr/lib/kf5/start_kdeinit
           │     ├─1248 kdeinit5: Running...
           │     ├─1249 /usr/lib/kf5/klauncher --fd=9
           │     ├─1268 /usr/bin/kded5
           │     ├─1272 /usr/bin/kwin_x11
           │     ├─1284 /usr/bin/ksmserver
           │     ├─1295 /usr/bin/kaccess
           │     ├─1297 /usr/bin/xembedsniproxy
           │     ├─1300 /usr/lib/polkit-kde-authentication-agent-1
           │     ├─1304 /usr/bin/plasmashell
           │     ├─1307 /usr/bin/baloo_file
           │     ├─1316 /usr/bin/gmenudbusmenuproxy
           │     ├─1477 /usr/lib/org_kde_powerdevil
           │     ├─1481 /usr/bin/remmina -i
           │     ├─1485 /usr/bin/pamac-tray-appindicator
           │     ├─1492 /usr/lib/geoclue-2.0/demos/agent
           │     ├─2226 file.so [kdeinit5] file local:/run/user/1000/klauncherUMhWGb.1.slave-socket lo>
           │     ├─

Not sure if this helps or not.

Barry

Did you check the preferences in pamac? You haven’t got the hide tray icon checked?

3 Likes

There is no update on pamac git for a week… So I do not understand.

@ricklinux Great suggestion, but the “hide tray icon …” is NOT checked.

@FredBezies It may have been doing this for longer, potentially even since the last update, I just don’t remember. I only noticed it about a week ago, and I kept awaiting an update in thoughts that it would fix the issue. I’m at a loss to understand, because all of my other systems are at the same version and are working perfectly.

Thanks for your replies!

Tried to rebuild pamac or those depency’s?

Believe vala was last week update?

1 Like

I uninstalled both packages using yay -Rns. I then reinstalled using yay -S with clean build option. Same behavior following reboot. Still no love …

Thanks, though, @ringo.

Barry

Stinks like a corrupted /etc/pamac.conf… Just a guess, of course. Will try in a VM with plasma. Could be a plasma bug.

Installed EndeavourOS + Plasma + Pamac and its tray app indicator. You still have it, but it is hard to see, because tray icon is white on a grey toolbar.

Switched to Dark breeze theme… And it is back!!

Hope it helps :slight_smile:

Thanks, but I already use dark breeze theme with dark/ black toolbar. No sign of the icon! (Nor is it in the “hidden icons” dropdown.)

Ouch! So, I do not understand :frowning:

This is a shot in the dark, since it doesn’t appear on your other systems, perhaps it is a graphic issue on this particular machine?

1 Like

Thanks for the idea. It’s an old HP Elitebook 8460p, circa 2010 I think (maybe earlier), with integrated graphics, no special drivers installed. No known graphics issues anywhere else. Here’s the config:

inxi -Gxxx
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
           vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0126 
           Device-2: Chicony Integrated HP HD Webcam type: USB driver: uvcvideo bus ID: 3-1.4:3 
           chip ID: 04f2:b230 serial: SN0001 
           Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: intel 
           unloaded: modesetting,vesa alternate: fbdev resolution: 1366x768~60Hz s-dpi: 96 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2) v: 3.3 Mesa 20.1.3 
           compat-v: 3.0 direct render: Yes 

Here’s an image of my toolbar with the missing icon.

Screenshot_20200712_090329

Also, I’ve explored all of the “gap” space on the toolbar to see if the icon is simply not appearing, but functionality remaining. Unfortunately, nothing I can find so far indicates that it is present.

Perhaps I should just await the next version update. Maybe it’ll trigger a “fix” at that time.

Found a bug like yours: https://gitlab.manjaro.org/applications/pamac/-/issues/851

1 Like

Thanks, Fred. I saw that report before I posted here (trying to do my research before I bothered everyone). Unfortunately, I couldn’t tell whether the -qt version bug was equivalent to my issue, as I’m still not very good reading the debugging output and, for some reason (user error), I couldn’t get pamac to run from terminal to be able to compare the QML output. (Thinking aloud: do I need to install the pamac-cli package? Is it compatible with my installed packages?)

As a matter of etiquette, should I have posted that link here at the outset? Would that have helped? I wasn’t trying to hide the ball or cause anyone extra work. I honestly didn’t think it was the same issue because the installed pamac version is different. Sincere apologies if I wasn’t thinking through that correctly.

You do not need to install pamac-cli. I will try some little things. Please, stay quiet until I ask you something.

Edit: can you type in a konsole this:

pamac-tray-appindicator &

And paste what is written in the shell? Thanks.

Not sure if you know this but @FredBezies is the maintainer of that package. If any one can fix this he can :grin:

Just sit tight and please provide whatever output he asks for.

1 Like

I do not say I’ll fix the bug, but I’ll do my best here.

2 Likes

As requested:

pamac-tray-appindicator &
[1] 641531

Yes, I know @FredBezies is the maintainer, and I am grateful for his assistance!

1 Like