Pacman up(dater)

Hi all
pacman updater refuses my root password ! Quite surprising & this stuff requires to be in weel !
But, as owner & inventor of this OS, I AM root (#) and in weel, automaticaly…So what the heck ?
I have to go thru pacman -Syu, as usual, but i really wonder what this so called “helper” needs ? Seems to be of some help
Do you have any kind of clues / ideas ?

Could you tell us the name of the pacman updtaer, since i think you’re talking about a GUI wrapper for Pacman? Do you mean Discover or Pamac?

Hi @Bryanpwo, its wrapper found on AUR, main package & gui for kde i’m using
I’ll have a good look at pacman.conf …
Discover works ok, so updates are done !
I still dont know why the root password is refused !
No typo,/keyboard mistakes ???
I could say never mind as system is up to date but i want to know the reasons…
& another feed i guess but i have no control (yet) on “apparmor” & “polkit”

What’s the name of the package?

apparmor is not installed unless you install it?

I see 2 pacman wrappers searching for ‘pacman’ with yay. pacmatic (not sure whether it’s gui or not) and yay itself…

Can you provide a screenshot of the app or terminal output if it doesn’t have GUI?

edit: actually not, sorry, there are plenty on AUR :sweat:

1 Like


better to give info because there is a lot wrappers :slight_smile:

look at this plasmoid :slight_smile:

for kde is also stil kalu-kde …kinda forked project i gues but stil a death end (kalu)…

fill us in is hard to tel :slight_smile:

Do you have a polkit agent installed and running on start?

Hi…yes, this is the one !
I also installed Apparmor but its not enabled (yet) !
Polkit was installed but is not enabled…
systemctl status xxxxx saying !
So i have to work all this around !

Re… I’m on Tumbleweed (Open-Suse) for the time being, but this morning (TZ +1)
there was a small update done with “discovery”…
Pacman icon shifts from red to green when stuff is done
Polkit not running & apparmor not running

octopi update notifier has 3 options if system is updated is octopi green, yellow for aur packages and red for updates…but is all setuptable.

do you use apparmor , because arch system general does not use apparmor. polkit should be running as dbus

Hi @ringo, apparmor is not enabled & poltkit is not enabled
octopi green after updates done thru discovery…(red before !)
i’ll try to set all this
Thanks for advises

i’ve updated alpm_octopi_utils & octopi, so i just wait for new updates and see !
In mean time i’ll have a good look at apparmor&polkit…

As i dont know but octopi has some settings to use which polkit. You have to look in there if its must use kdsu lxqt-sudo or something else? Ubuntu ships apparmor standard endeavouros not unless you install snap! If you do pacman -Qs apparmor you wil see nothing other hand polkit is there

Hi @ringo, back again but on Tumbleweed…
On the machine with End.OS, snap is installed & i must say that i said tchao to
Canonical stuff some time ago !!!
Thanks again & i will follow u’r trick and have a good look at the aur, just in case !
Kind of gold mine & filled up with heavy experiences and ways to go back (in case)

1 Like

@ringo, i had a look at “polkit-explorer” witch is a good thing, but i guess i have a long way to go