Pacman segfaults on --sync

After a few weeks (waiting for Plasma6 to stabilise a bit) I tried to upgrade my system and was met with some segfault oddness.

These are the last lines I get from sudo pacman --sync --refresh --sysupgrade --debug:

[…]
debug: checkdeps: missing dependency 'qt6-base' for package 'kmime'
debug: finished resolving dependencies
debug: pulling dependency kmime (needed by akonadi-contacts)
debug: started resolving dependencies
debug: checkdeps: package ktextaddons-1.5.4-1
debug: checkdeps: missing dependency 'karchive' for package 'ktextaddons'
debug: checkdeps: missing dependency 'kcolorscheme' for package 'ktextaddons'
debug: checkdeps: missing dependency 'kconfig' for package 'ktextaddons'
debug: checkdeps: missing dependency 'kconfigwidgets' for package 'ktextaddons'
debug: checkdeps: missing dependency 'ki18n' for package 'ktextaddons'
debug: checkdeps: missing dependency 'kio' for package 'ktextaddons'
debug: checkdeps: missing dependency 'kwidgetsaddons' for package 'ktextaddons'
debug: checkdeps: missing dependency 'qt6-base' for package 'ktextaddons'
debug: checkdeps: missing dependency 'qt6-speech' for package 'ktextaddons'
debug: checkdeps: missing dependency 'qtkeychain-qt6' for package 'ktextaddons'
debug: checkdeps: missing dependency 'sonnet' for package 'ktextaddons'
debug: checkdeps: missing dependency 'syntax-highlighting' for package 'ktextaddons'
debug: started resolving dependencies
debug: checkdeps: package qt6-speech-6.6.3-1
debug: checkdeps: missing dependency 'qt6-base' for package 'qt6-speech'
debug: checkdeps: missing dependency 'qt6-multimedia' for package 'qt6-speech'
debug: started resolving dependencies
debug: checkdeps: package qt6-multimedia-6.6.3-1
debug: checkdeps: missing dependency 'qt6-base' for package 'qt6-multimedia'
debug: checkdeps: missing dependency 'qt6-multimedia-backend' for package 'qt6-multimedia'
debug: provider found (qt6-multimedia-ffmpeg provides qt6-multimedia-backend)
debug: provider found (qt6-multimedia-gstreamer provides qt6-multimedia-backend)

error: segmentation fault
Please submit a full bug report with --debug if appropriate.
fish: Job 1, 'sudo pacman --sync --refresh --…' terminated by signal SIGSEGV (Address boundary error)

And here is the full pastebin

I tried to just update yay firefox and later also yay pacman and that worked fine :person_shrugging:

Almost two weeks later, I still get the this issue.

I apologise for the bump, but this I would very much appreciate help and online search did not help me at all so far. The problem did not go away either.

I would really like to avoid something as drastic as a system re-install :confused:

Have you tried updating the mirror list and re-running the upgrade?

1 Like

I did.

Just in case I did it again:

eos-rankmirrors; eos-update

again, segfault after eos-update.

what happens if you update via pacman?

sudo pacman -Syu

1 Like

I tried sudo rm /var/lib/pacman/db.lck; sudo pacman -Syu again, and now it worked. :person_shrugging:

No idea why it didn’t (many times) before, but I’ll take it :frog:

Thanks :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.