Pacman can't install anything because of a PGP key?

Earlier I was trying to install a driver for my graphic card before realising I did not need it. I pasted a bunch of install commands and it gave me the error

error: rumpowered: key "E78F977D7BBB55791EB097B4CC7A2968B28A04B3" is unknown
error: database 'rumpowered' is not valid (invalid or corrupted database (PGP signature))

I said no to the install and moved on. However this error is following me when I try to install anything else.
I want to install mongo-tools and I still get an error for this key. I cannot update my system either.
I have run pacman -Syu and pacman -Syyu and pacman -Ss as I found on other posts on this forum but the error persists. How can I get pacman to forget about this package/key?

You appear to have added an unofficial repo to pacman.conf that you don’t have the key for.

If you remove that repo from pacman.conf, you should be able to run pacman commands again.

1 Like

Hi, thank you for the reply.
Is there a way to tell what package it is? I installed using a command of maybe 10 different packages, it was supposed to be everything I needed for gaming.
I have tried sudo pacman -R rumpowered and it was not the package name
edit: I found the command that did it, I am just not sure how to undo it

echo '
Server =$arch ' | sudo tee -a /etc/pacman.conf
sudo pacman-key --recv-keys cc7a2968b28a04b3
sudo pacman-key --lsign-key cc7a2968b28a04b3

Just open pacman.conf with an editor and remove those lines.

sudo nano /etc/pacman.conf

Find these lines:

Server =$arch

Delete them, then save the file and quit.


This worked, thank you so much for your help.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.