Pacman 5.2.1-1 can't install

hi, i have a problem updating pacman. instalando pacman (5.2.1-1) se rompe la dependencia con «pacman<5.2», necesaria para el paquete kalu i need help, or die…

Uninstall kalu and try again.

Hi @fernandoganem,

yes it’s normal folllow the answer here :

sudo pacman -Rs kalu

reboot, then…

sudo pacman -Syu

then install package “eos-update-notifier”

sudo pacman -S eos-update-notifier

then reboot


Why rebooting twice? That’s Linux. :wink:

1 Like

I think the first reboot is not necessary.
And second, a relogin would be enought.
If someone did like this and could confirm it…

In my opinion, when a package with its dependencies (-Rs) is de-installed or deleted, it is good to restart and reload the session.

When installing a new package, it is not necessary, unless it is a kernel.

1 Like

Relogin should be enough after installing eos-update-notifier. But reboot doesn’t hurt either… :wink:

1 Like

thank you so much. problem solved.

Thank you. This worked for me, as well, without second reboot. All is functioning as expected.

Welcome here!

And great to hear that you got system working as it should. :slight_smile: