Overcoming a bootup / install glitch 🤷🏽

Been enjoying EOS for some time now, but am hitting a wall trying to install on my MacMini (mid-2011) with an ISO created using balenaEtcher …

This same flash thumbdrive happily brings up the live version on other machines (2019 iMac, 2011 MacBookPro, Dell Optiplex) but NOT this poor old MacMini. I have no problem loading Manjaro or Kali on it, but not (the latest) EOS live/installer (which seems to rule out a thumbdrive or USB port problem … having tried each USB port on the Mini just in case… and I’ve tried burning a fresh EOS image to various thumbdrives and SDcards repeatedly without success).

FYI, the following is as far as I most recently got when selecting the ISO thumbdrive (which always appears as one of the boot up options) to boot up (via “Opt+PowerOn”)…

I’d offer up inxi or other run-time info, but obviously I can’t run, so not much of an option :wink:

This must be a simple issue for those in the know. But obviously I’m not one of them yet. :man_shrugging:t4:

Any suggestions appreciated!

[EDIT: Here’s a thought … since I can get Kali to recognize the thumbdrive as “EOS_202308”, is there a way to install EOS using the up-and-running Kali linux terminal - rather than from a power-up boot up stance?]

no clue why it does not boot on this onme… is it the same when using original arch ISO?
You have tried latest weekly rebuild of EndeavourOS ISO?

Thanks for the suggestion … am now downloading the link you’ve provided and will give that a go later on.

No, I didn’t try an original Arch install (interesting thought - worth pursuing) but the Manjaro (Arch-based) and Kali (Debian) ISOs weren’t a problem as they’re both loaded and functional when selected at boot up.

I keep trying to install EOS (my favorite) using different combinations of input ports (USB, SD card) on the MiniMac and various media (assortment of flashdrives, SD cards, various sizes, etc.).

Haven’t hit upon the way yet to get it to move beyond that error message shown above when trying to install the ISO for EOS. Does it have to be installed during bootup? If not, perhaps I can invoke it to install while the system is already up and running under a different linux distribution.

Anyhow, seems like a strange error message that requires more kernel savvy than I’ve got :wink:

@joekamprad UPDATE: Interesting outcome…

Having flashed the unpacked “Release 2023-10-13_00-10” EOS ISO file to a thumbdrive…

I first confirmed that the live boot function works perfectly on my 2019 iMac, indicating that the thumbdrive is all set to go. But then…

Using that thumbdrive on both my mid-2011 MacMini and 2011 MacBookPro, although the grub menu presents itself as expected, once selecting (or letting it default to) that first EndeavourOS choice, both the thumbdrive’s LED and the monitor both go dark and stop functioning just a few seconds later.

Despite waiting a long time, no further notice nor any error message is ever provided.

[FWIW, this same MacBookPro laptop already has a perfectly functional EOS/i3 operating system - fully updated as always - i.e., my default OS and much loved. So at least we know the hardware itself is up to the task.]

Next, I’ll try the vanilla Arch installation ISO and report back.

UPDATE #2: Trying the same with the latest vanilla Arch ISO I get the same outcomes as above…

I.e., the thumbdrive loads perfectly on the 2019 iMac but on both my 2011 MacMini and 2011 MBPro laptop, the process chokes immediately after the GRUB menu stage - such that both the screen and the thumbdrive go dark and blank. No error message.

Presumably, whatever is causing this stems from something going on at the Arch level, not necessarily EOS’s ISO.

FWIW, both the MacMini and MBPro laptop have successfully got (older) Manjaro installations from before I discovered EndeavourOS, which suggests Arch didn’t have this issue at some in the past. And my MBPro has been running EOS for about a year now with regular updates throughout.


UPDATE #3: Tried using an ISO of blackarch. Same outcomes across the board - works on 2019 iMac but chokes just past the grub screen on both 2011 MacMini and 2011 MBPro laptop.

Strongly suggests an Arch-based problem with these particular 2011-vintage Mac hardware boxes has been introduced at some point (not a problem in the past).

Perhaps my next attempt should be to dredge up legacy ISOs of EOS.