Other OS not appearing in grub

Hi again!

I recently installed Gentoo on another drive but it isn’t appearing in EnOS grub.

os-prober shows:

/dev/nvme0n1p3:Gentoo Linux:Gentoo:linux

I have GRUB_DISABLE_OS_PROBER=false in my /etc/default/grub, and upon running grub-mkconfig -o /boot/grub/grub.cfg I get:

Generating grub configuration file ...
Found theme: /boot/grub/themes/EndeavourOS/theme.txt
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Gentoo Linux on /dev/nvme0n1p3
Adding boot menu entry for UEFI Firmware Settings ...

However there is no menuentry for Gentoo in /boot/grub/grub.cfg and indeed won’t show up in grub.

I’m running out of ideas, I’d appreciate some help!

Have you tried reinstalling grub? sudo pacman -s grub

1 Like

That could do it, I’ll try. Give me a moment.

Thanks for the suggestion, but Gentoo still isn’t showing up.

Maybe check this out.

1 Like

Now it’s showing up, but displaying an error.

If I understood that correctly, I mounted my Gentoo partitions like so:

mount /dev/nvme0n1p3 /mnt/gentoo
mount /dev/nvme0n1p1 /mnt/gentoo/boot

And ran grub-mkconfig -o /boot/grub/grub.cfg once again.

Now, Gentoo has a menu entry! But when I enter it, I get a black screen with:

error: file '/boot/vmlinuz-5.15.75-gentoo-x86_64' not found.
error: you need to load the kernel first.

I’ll look into it later, but if anyone has any suggestion what to do, please share.

says fixed when mounting the only gentoo boot partition under /mnt before running os-prober … so not what you have done mounting both


Oh, you’re totally right, my bad!

Did that, and now it’s working! Thank you so much :smiley:


¡Es un placer!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.