OS unusable after first reboot

I recently did a fresh install of the Qtile community edition. The first boot into it works just fine, however the second time I get into it is broken. I can still navigate and do some things such as open programs like a browser etc. But a lot of commands simply don’t work.

Some commands I tried after the reboot that don’t work are, nmcli, making with dkms, and even the reboot command.

Basic things such as ls and cd work.

I type the command into the terminal and the cursor goes to the next line and does nothing.

I tried connecting with USB tethering as well and it won’t even recognize the USB I believe. So perhaps it’s hardware related.

And to reiterate, everything works completely fine on the initial boot of the system.

I’m not really sure what logs or information would need to be provided so let me know.

ls and cd are probably shell built-ins.

You can try and see if you can get logs with journalctl -b -p err.

If that command won’t run, try booting off the ISO, chrooting into the system as described in the wiki and running the command that way.

1 Like
  1. welcome here :enos:

  2. if possible share your hardware info: inxi -Fxxc0z or if you are able to connect to internet inxi -Fxxc0z | eos-sendlog

Just checked qtile install… and i see it still has picom enabled by default this can caus issues like you have in cases… you could try commenting it in autostart.sh

1 Like

Sorry if it’s wrong to post a picture but USB tethering is not working for internet

So the journalctl command is working but other commands are not?

1 Like

Correct that one did work for some reason, the inxi command that was also suggested did not however

Can you see if any more errors were added in journalctl after the failed command?

1 Like

Yes, this last line was added. Not sure if it was specifically from the inxi command though

Can you disconnect any USB devices outside of keyboard/mouse and see if the issue persists?

1 Like

Ok, I tried that and problem still persists. I am now experiencing heavy delay of OS as a whole. Which leads to my previous though of a hardware issue, but to clarify my hardware is working fine on windows install I have on separate SSD. So maybe a problem with the relationship between the Linux os and my hardware.

Should chroot with the live iso to try the inxi command or stay here?

It could be a lot of things. A failing ssd for example. An issue with memory or something else all together.

1 Like

I’ve re installed eos three times due to this problem. 2 online and one offline. They all work fine in the first boot. It is only after I shutdown the first time and reboot back into it that this problem happens.

I know my hardware has no issues itself as I can run my separate windows installation just fine and because the first boot works.

This is only after rebooting.

Is this just an esoteric, unsolvable issue?

This has no real meaning. Windows and Linux stress hardware in different ways. Sometimes failing hardware will appear to be working in Windows and broken in Linux. The opposite is also possible.

Probably not. We just need to work towards the root cause.

Can you boot off the ISO and get the inxi information @joekamprad asked for?

1 Like

Ok, yes I am doing that now

[root@EndeavourOS /]# inxi -Fxxc0z
  Kernel: 6.2.8-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.1 Console: N/A wm: xfwm
    DM: startx Distro: EndeavourOS base: Arch Linux
  Type: Desktop System: Micro-Star product: MS-7A34 v: 3.0 serial: N/A
  Mobo: Micro-Star model: B350 TOMAHAWK ARCTIC (MS-7A34) v: 3.0 serial: <filter>
    UEFI: American Megatrends v: H.60 date: 07/27/2017

(upower:21): UPower-WARNING **: 16:54:22.002: Cannot connect to upowerd: Could not connect: No such file or directory
  Device-1: hidpp_battery_0 model: Logitech Wireless Mobile Mouse MX Anywhere 2 serial: <filter>
    charge: Full status: discharging
  Info: quad core model: AMD Ryzen 5 1500X bits: 64 type: MT MCP arch: Zen rev: 1 cache:
    L1: 384 KiB L2: 2 MiB L3: 16 MiB
  Speed (MHz): avg: 1731 high: 3000 min/max: 1550/3500 boost: enabled cores: 1: 3000 2: 1550
    3: 1550 4: 1550 5: 1550 6: 1550 7: 1550 8: 1550 bogomips: 56014
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: eVga.com. driver: nvidia v: 530.41.03
    arch: Pascal pcie: speed: 2.5 GT/s lanes: 16 ports: active: none off: DVI-D-1,HDMI-A-1
    empty: DP-1,DP-2,DP-3 bus-ID: 23:00.0 chip-ID: 10de:1c03
  Display: server: X.org v: compositor: xfwm driver: X: loaded: nvidia
    unloaded: modesetting alternate: fbdev,nouveau,nv,vesa gpu: nvidia,nvidia-nvswitch
    display-ID: :0.0
  Monitor-1: DVI-D-1 model: Acer GN246HL res: 1920x1080 dpi: 92 diag: 609mm (24")
  Monitor-2: HDMI-A-1 model: Samsung res: 1920x1080 dpi: 48 diag: 1168mm (46")
  API: OpenGL Message: GL data unavailable for root.
  Device-1: NVIDIA GP106 High Definition Audio vendor: eVga.com. driver: snd_hda_intel v: kernel
    pcie: speed: 2.5 GT/s lanes: 16 bus-ID: 23:00.1 chip-ID: 10de:10f1
  Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie:
    speed: 8 GT/s lanes: 16 bus-ID: 25:00.3 chip-ID: 1022:1457
  Device-3: Logitech Zone Wireless Plus driver: hid-generic,snd-usb-audio,usbhid type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 bus-ID: 1-8.2.1:8 chip-ID: 046d:0aa8
  Device-4: Focusrite-Novation Scarlett 4i4 USB driver: snd-usb-audio type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 bus-ID: 2-1:2 chip-ID: 1235:8212
  Device-5: C-Media Blue Snowball driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 bus-ID: 2-4:3 chip-ID: 0d8c:0005
  API: ALSA v: k6.2.8-arch1-1 status: kernel-api
  Server-1: PipeWire v: 0.3.70 status: n/a (root, process) with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI
    driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 21:00.0
    chip-ID: 10ec:8168
  IF: enp33s0 state: down mac: <filter>
  Device-2: NetGear A6100 AC600 DB Wireless Adapter [Realtek RTL8811AU] driver: N/A type: USB
    rev: 2.1 speed: 480 Mb/s lanes: 1 bus-ID: 1-7:2 chip-ID: 0846:9052
  IF-ID-1: enp3s0f0u8u3 state: unknown speed: -1 duplex: half mac: <filter>
  Local Storage: total: 2.07 TiB used: 6.83 GiB (0.3%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 960 EVO 250GB size: 232.89 GiB speed: 31.6 Gb/s
    lanes: 4 serial: <filter> temp: 36.9 C
  ID-2: /dev/sda vendor: Seagate model: ST2000DM006-2DM164 size: 1.82 TiB speed: 6.0 Gb/s
    serial: <filter>
  ID-3: /dev/sdb vendor: PNY model: USB 3.0 FD size: 28.87 GiB type: USB rev: 2.1 spd: 480 Mb/s
    lanes: 1 serial: <filter>
  ID-1: / size: 907.16 GiB used: 6.83 GiB (0.8%) fs: ext4 dev: /dev/dm-0 mapped: mapper
  ID-2: /boot/efi size: 512 MiB used: 448 KiB (0.1%) fs: vfat dev: /dev/sda1
  Alert: No swap data was found.
  System Temperatures: cpu: 45.1 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 233 Uptime: 24m Memory: available: 7.71 GiB used: 966.4 MiB (12.2%) Init: systemd
  v: 253 default: graphical Compilers: gcc: 13.1.1 Packages: pm: pacman pkgs: 798
  Client: Unknown Client: systemd inxi: 3.3.27
[root@EndeavourOS /]# inxi -Fxxc0z | eos-sendlog

(upower:80): UPower-WARNING **: 16:54:38.740: Cannot connect to upowerd: Could not connect: No such file or directory
/usr/bin/eos-sendlog: line 191: /root/.config/eos-sendlog.txt: No such file or directory

Not sure where autostart.sh is or specifically what you’re asking me to do with it

simply comment the line starts with picom …
it is also already autostarting on its own… so may remove the package to see if you can load the WM without it…
sudo pacman -R picom


Neither worked, WM wouldn’t load without picom.

Did the output of inxi reveal anything?

You have a lot of audio USB devices connected and Googling your error cannot set freq 48000 to ep 0x3 reveals it may be audio HW related. But I understand initial error is different. Anyway, for a time of troubleshooting I would disconnect everything.

Do you update your system before rebooting? You are not using latest kernel, so maybe update will solve problem? Also you can try to install some 5.x LTS kernel before first reboot - this way you can check if it is some weird kernel regression.

IDK this Endeavour edition… Would try also with some Ubuntu , then normal Endeavour before jumping on community edition. My understanding is this is your first Linux in that PC.

PS. To be on safe side, disconnect one of monitors as well.

can you add on boot kernel
“iommu=pt processor.max_cstate=5”

there is a bug kernel , better send all eos log

and please update your UEFI motherboard

UEFI: American Megatrends v: H.60 date: 07/27/2017


you may have to downgrade firmware for your cpu ( before may 2023 release )

1 Like