Optical drive not found [SOLVED]

Hello all!

I have an integrated optical dvd-drive, but nothing really in /dev to access it. Programs looking into /dev/cdrom or /dev/sr0 find nothing. My user is in group optical. I have tried LTS and zen kernels. I suspect suspect some kernel module needs loading, but I don’t remember where I got that idea from. Any ideas?


Fix: install audiocd-kio

sudo pacman -Syu audiocd-kio
1 Like

A better solution would be this i think?

Note: running with sudo does not work

su root
echo sg > /etc/modules-load.d/sg.conf

audiocd-kio was missing and needed anyway for dolphin filemanager to browse the disc. Before that I tried loading the sg module but that didn’t help, but I didn’t check if loading at boot would’ve worked

9 months later

1 Like

Yes :sweat_smile: I guess I just lived without it.

also it’s pretty funny that after 9 months of silence and figuring the fix out oneself, THEN come the replies “why not this solution instead?” :grinning: very stack-overflowy vibes. No offence! I do appreciate all the help :pray:

will be even usfull after the next 9 month i think… so i put it in plasma subforum…


Is not installed by default, and adding sg module to be loaded is not needed on kde/plasma with it installed as far as i know?

Well i did realized after i posted that it has been 9 months…

On XFCE loading sg module is necessary, makemkv won’t find any drives without it.
Installing audiocd-kio on kde plasma might only work for kde apps like k3b? I don’t know as i use xfce.

1 Like
kernel: scsi 6:0:0:0: CD-ROM            HL-DT-ST DVD+-RW GTA0N    A1B0 PQ: 0 ANSI: 0
kernel: scsi 6:0:0:0: Attached scsi generic sg4 type 5
kernel: sr 6:0:0:0: Power-on or device reset occurred
kernel: sr 6:0:0:0: [sr0] scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
kernel: cdrom: Uniform CD-ROM driver Revision: 3.20
kernel: sr 6:0:0:0: Attached scsi CD-ROM sr0

i do only have a USB DVD drive this is working ootb no need to load the module manually

I’m not sure if there is any difference between a usb or internally dvd drive?
In xfce i use internal drives (pioneer and LG) and sg is needed for makemkv to find the drive

Interesting, i might test it with eos live kde to see what happens then

i did try it in kde plasma (galileo live) and installed makemkv.
makemkv can’t find any drives.

Then i installed audiocd-kio (not rebooted after)
makemkv still can’t find any drives

then loaded sg module
sudo modprobe sg
makemkv finds the drive!

Maybe makemkv is differently coded?

rebooted the live version and installed k3b
k3b did find the drive without audiocd-kio installed
So dvd drives are only found in kde applications but not in makemkv

It seems that makemkv needs both /dev/sr* and /dev/sg* in place to be working

I used a fresh default install. The live usb says version 2023.08.05, I’m not sure if that’s the latest but not terribly old at least.

I got the idea of installing the audiocd-kio because the dolphin fm showed a gui error of “somethingsomething kio … not found” when opening the disc. My hardware is ~10 years old so also might be some compatibility got dropped off along the way, as I remember it working out of the box some years ago.