Openssh update may broke ssh-copy-id

Hello forum, I’m not sure why this is happening, but started after the openssh latest update.
Can someone test to confirm?

cat /var/log/pacman.log
[2020-10-05T15:51:29-0300] [ALPM] upgraded openssh (8.3p1-4 -> 8.4p1-1)

[marcelo@linux ~]$ ssh-copy-id root@firewall
/usr/bin/ssh-copy-id: INFO: attempting to log in with the new key(s), to filter out any that are already installed
/usr/bin/ssh-copy-id: INFO: 1 key(s) remain to be installed -- if you are prompted now it is to install the new keys
/usr/bin/ssh-copy-id: linha 251: aviso: here-document na linha 251 delimitado pelo fim do arquivo (desejava `EOF')
/usr/bin/ssh-copy-id: linha 250: aviso: here-document na linha 250 delimitado pelo fim do arquivo (desejava `EOF')
/usr/bin/ssh-copy-id: linha 254: /dev/null`: Permissão negada
/usr/bin/ssh-copy-id: linha 260: EOF: comando não encontrado

Already tried to remove the keys inside /home/user/.ssh/known_hosts but the same error happens

1 Like

If someone faces this problem, downgrade the package:
It’s working now.

[marcelo@linux .ssh]$ downgrade openssh
Pacotes disponíveis:

    1)  openssh    8.0p1  1  x86_64  (remoto)
    2)  openssh    8.0p1  2  x86_64  (remoto)
    3)  openssh    8.0p1  3  x86_64  (remoto)
    4)  openssh    8.1p1  1  x86_64  (remoto)
    5)  openssh    8.1p1  2  x86_64  (remoto)
    6)  openssh    8.1p1  4  x86_64  (remoto)
    7)  openssh    8.2p1  1  x86_64  (remoto)
    8)  openssh    8.2p1  3  x86_64  (remoto)
    9)  openssh    8.3p1  1  x86_64  (remoto)
   10)  openssh    8.3p1  2  x86_64  (remoto)
-  11)  openssh    8.3p1  3  x86_64  (remoto)
-  12)  openssh    8.3p1  4  x86_64  (remoto)
-  13)  openssh    8.3p1  4  x86_64  (local)
   14)  openssh    8.3p1  5  x86_64  (remoto)
+  15)  openssh    8.4p1  1  x86_64  (remoto)
+  16)  openssh    8.4p1  1  x86_64  (local)

selecione um pacote por número:14
 openssh-8.3p1-5-x86_64          892,7 KiB   765 KiB/s 00:01 [--------------------------------] 100%
 openssh-8.3p1-5-x86_64.sig      566,0   B  0,00   B/s 00:00 [--------------------------------] 100%
carregando pacotes...
atenção: fazendo downgrade do pacote openssh (8.4p1-1 => 8.3p1-5)
resolvendo dependências...
procurando pacotes conflitantes...

Pacotes (1) openssh-8.3p1-5

Tamanho total instalado:   5,24 MiB
Alteração no tamanho:   -0,10 MiB

:: Continuar a instalação? [S/n] S
(1/1) verificando chaves no chaveiro                         [--------------------------------] 100%
(1/1) verificando integridade do pacote                      [--------------------------------] 100%
(1/1) carregando arquivos do pacote                          [--------------------------------] 100%
(1/1) verificando conflitos de arquivos                      [--------------------------------] 100%
:: Processando alterações do pacote...
(1/1) fazendo downgrade openssh                              [--------------------------------] 100%
:: Executando hooks pós-transação...
(1/3) Reloading system manager configuration...
(2/3) Creating temporary files...
(3/3) Arming ConditionNeedsUpdate...
adicionar openssh em IgnorePkg? [s/N] N

can it be due to older version on remote (happened once in the past)?

as (more cumbersome) alternative, one can opt for the manual method suggested in there.

1 Like

a little side tip:
any terminal command can output in english if you put LANG=C in front:
LANG=C downgrade openssh


Nice, thanks, I wasn’t aware of it :slight_smile: