Openbox for the first time

So you used a project that has been dead since 2016 and now you are complaining really

Actually, I explained that I have been trying out various installers. PacBang was mentioned here as being still in use and possibly updated. It was worth a try. FWIW, I also pointed out that I have been doing this on an external SSD (SATA to USB) and that could well be why these installs don’t seem to work very well.

Your comment, however, smacks of the sort of retort that is common on the Arch Linux forum. We generally stay away from that style on this EndeavourOS forum where politeness and helpfulness is the key.

Now now take it easy. @mandog is one of the creators of pacbang.


So lets make this clear You took a ISO from sourceforcge that has not been maintained 2016 right expecting it to work, Well it did sort off and that in its own is amazing i would say. then you slate it off?

Manjaro does a unofficial OB spin the maintainer makes a claim well what ever he claims it not Pacbang as Pacbang was pure Arch not Manjaro.
That being said I’m led to believe it is much lighter than previous Manjaro attempts of OB. Perhaps it might be for you try it.

Yes, I was misled. I downloaded the sourceforge image and in my file manager it showed as ‘pacbang-2020.01.04-x86_64.iso’. From the discussion here and elsewhere, and the file name, I gained the impression that it was being updated. So I tried it. I mentioned above that I have been trying various installers out of interest. On my main computers I have installed Vanilla Arch with Openbox, i3 and bspwm. I usually can install a basic Arch in about 15 minutes.

Purely out of interest, today I installed Anarchy on my external SSD and it was perfect. Naturally, I now know that Pacbang is way out of date and won’t touch it with a bargepole.

Have a nice day.


I like Anarchy too but it has an issue installing with EndeavourOS. I can’t get it to dual boot with EndeavorOS. Usually one or the other won’t boot depending on which has the bootloader. I didn’t try to figure it out but i do like the installer and it works well on it’s own.

I recently installed a second distro on an empty partition but because I also had Windows on the same disk I didn’t want to risk affecting the windows bootloader, so I didn’t mount any /boot or /boot/efi and ignored the warning during the install.
I then ran grub-customizer (which runs refind) in my main Linux instance (which lives on a second drive) and it detected the new distro and added it to my already existing boot menu (which also contains my Windows boot entry added in the same fashion).

I’m glad everything worked out for you in the end, Lesson learned is this happens a lot on Sourceforge, not saying its Sourceforge but unscrupulous 3 rd parties.


Update 2
I’ve moved on from Manjaro Openbox. I really liked Openbox, but not so much Manjaro (too long of a discussion to get into here). After some deep soul searching on what I really wanted from my notebook computer, I settled on LXQt. So I’m through tinkering for a while. KDE/Plasma on the desktop and LXQt on the Lenova Z510. I’m even using pamac-git when I need a gui installer instead of octopi. “Who would’ve thunk it?”

1 Like

well… that’s that then.

Moving on, I tried LXQt a year or so ago and was terribly disapointed. I uninstalled it immediately. It seemed half baked and awful looking. Thinking back a bit it might just be that I tried it in a specially bad looking distro flavor.
What makes you choose it over something else? I mean if it’s lightweight and specifically qt you’re looking for that makes sense. But is there anything else that makes it special?

Yes, you guessed it, Qt and lightweight. Since I run KDE on my desktop I decided to stick with Qt. Even though KDE is now pretty efficient, it still felt heavy on a laptop. LXQt seems complete and nice now. Or my expectations are pretty low. :grinning:

1 Like

If I had to settle for a Qt environment I would definitely pick LXQt over Plasma. But as I have said many times Plasma and I just don’t get along. But neither does Gnome and me.

1 Like

my first attempt to install openbox with EndeavourOS:

  • transparency: picom
  • panel: tint2
  • terminal: xfce4-terminal
  • filebrowser: Thunar

how did yo do that joe, I have endeavouros xfce

sudo pacman -S openbox obconf lxinput lxrandr arandr menumaker xdg-user-dirs-gtk archlinux-xdg-menu picom tint2 --needed

thanks for the above Joe, with me having xfce, does this allow me to use openbox and xfce, or just openbox?

this will insttall needed packages additional… and openbox is unconfigured, you need to setup completely on your own it is a Window Manager you could also use inside xfce4 as window manager…

so at log in, I could log in as openbox or xfce?

on Login Manager (Desktop Manager) you can choose both xfce4 or openbox then…

thanks Joe, will give it a try