"Open File" window beyond the screen size in libreoffice

I would like to say Hi to everyone, as this is my first post. My current system is Manjaro, but I’m testing Endeavour i3wm on my secondary laptop. As I like the distro very much I’m considering switching, but I have to be sure that I will not encounter any major problems that I can’t solve. Speaking of the problems I encountered one that I have trouble with:

When “Open File” in libreoffice is selected the window opens into huge size beyond the size of the screen.
This is unusual b/c on my other machine (with Manjaro i3) this problem does not exist. I would like to add that when selecting Tools>Options the window is normal size.

I suspect that this has something to do with my HDPI screen settings but, I have no idea how to fix this, so any input would be greatly appreciated.

i3wm endeavour machine xps13 9300 resolution 3840x2400
I3wm manjaro machine xps 13 9380 resolution 3840x2160

I don;t know much of i3 - but anything that can cause a window too big for that resolution must really have lost the plot! I would start to look for double settings, like increased dpi and the equivalent of –force-device-scale-factor=2 acting on things.

Good luck!

Hopefully an i3 expert will be along...

I think this is a bit more complicated. The fonts in the window in question are the proper size, just the size of the window is out of proportions. I do have setting to increase dpi (on both systems) which allows me to read the text without using a microscope :slightly_smiling_face:

Might not be a bad idea to post inxi -Fza, bracketed by triple backticks `, for reference purposes…

Is the window floating of tilling? Tilling cannot go beyond monitor border as far as I know.

For floating window you can specify in your i3config something like this.

for_window [class="^Soffice$" title="^Open$"] floating enable move position 50 px 30 px, resize set 600 px 800 px

Soffice is class category of libreoffice dialog windows on my system. Yours may differ.
Position is from left and from top
Resize is width, height

Reload your i3 session when you put this in your config.

Or you can just use

for_window [class="^Soffice$" title="^Open$"] floating disable

to force it in tilling mode, I think.

If your problem is that the font is too big and therefore the window is also too big then it may require a slightly different approach.

1 Like

Thanks, this probably will work. Before I got your post I actually tried something similar, namely, I made the window tille. This actually fixed the issue.

Thanks for all your help!