Only large mouse cursor showing after update

Odd behavior after updating one om my machines.
it seems plasma desktop is stuck loading or something.
After the kde loading screen, all that shows is an oversized mouse cursor.
It does this in both lts as well as linux.

I can however get to ctrl+alt+f2

At this point I’m unsure how to proceed.

From what I can tell sddm might be crashing.
from consol if I run

systemctl restart display-manager

a couple times it will come in.

I managed to get gdm installed and it booted
What a nightmare, can’t find anything and totally lost in that mess and slow as hell. sry if that bugs anyone, just saying I found out that much.

I’ll just leave that machine run and hope an update fixes it as thats my sons home school machine.

If anyone has any suggestions other than wait, please feel free to.

$ inxi -F
  Host: DCH Kernel: 5.15.91-1-lts arch: x86_64 bits: 64 Desktop: KDE Plasma
    v: 5.26.5 Distro: EndeavourOS
  Type: Desktop System: Dell product: Inspiron 620 v: 00
    serial: <superuser required>
  Mobo: Dell model: 0GDG8Y v: A00 serial: <superuser required> BIOS: Dell
    v: A04 date: 11/21/2011
  Info: dual core model: Intel Core i3-2120 bits: 64 type: MT MCP cache:
    L2: 512 KiB
  Speed (MHz): avg: 1596 min/max: 1600/3300 cores: 1: 1596 2: 1596 3: 1596
    4: 1596
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    driver: i915 v: kernel
  Display: x11 server: X.Org v: 21.1.6 driver: X: loaded: intel
    unloaded: fbdev,modesetting,vesa dri: i965 gpu: i915
    resolution: 1024x768~75Hz
  API: OpenGL v: 3.3 Mesa 22.3.4 renderer: Mesa Intel HD Graphics 2000 (SNB
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    driver: snd_hda_intel
  Sound API: ALSA v: k5.15.91-1-lts running: yes
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Sound Server-2: PipeWire v: 0.3.65 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: d0:67:e5:28:9e:1e
  Local Storage: total: 298.09 GiB used: 207.89 GiB (69.7%)
  ID-1: /dev/sda vendor: Western Digital model: WD3200AAJS-22B4A0
    size: 298.09 GiB
  ID-1: / size: 95.56 GiB used: 74.99 GiB (78.5%) fs: ext4 dev: /dev/sda2
  ID-2: /boot size: 966.8 MiB used: 124.8 MiB (12.9%) fs: ext4
    dev: /dev/sda1
  ID-3: /home size: 193.34 GiB used: 132.77 GiB (68.7%) fs: ext4
    dev: /dev/sda4
  ID-1: swap-1 type: partition size: 1.95 GiB used: 0 KiB (0.0%)
    dev: /dev/sda3
  System Temperatures: cpu: 27.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 2634 mobo: 915
  Processes: 180 Uptime: 16m Memory: 3.75 GiB used: 2.19 GiB (58.4%)
  Shell: Bash inxi: 3.3.24

Are you using xf86-video-intel driver?

$ lspci -k | grep -EA3 ‘VGA|3D|Display’
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
Subsystem: Dell Device 04ed
Kernel driver in use: i915
Kernel modules: i915

Have you tried it without the Intel driver so it’s running on the kernel module.

I have not as this is the install driver that has always gone in automatically. It never asked in all these years to install a superior driver.


can you provide more details,

eos-sendlog < /var/log/Xorg.0.log


journalctl -b -0 --no-hostname | eos-sendlog

Regarding the driver, it is fine; xf86-video-intel is better for your Gen2 graphics anyway, you don’t need to change anything.

Also, make sure you are using mesa-amber instead of mesa

mesa-amber is the legacy Mesa package which includes the classic (non-Gallium3D) drivers for Gen 2 hardware and later. This driver has better performance and stability for Gen 7 and older hardware.

For more info check the arch wiki

xf86-video-intel is what it was using which I figured was what it should be using.

But I’ll be dipped.
It never actually occurred to me to just take it out and try it.
Taking it out has even fixed the flicker and lag I’ve always dealt with when I connect to it through

As far as xf86-video-intel goes, It isn’t a major deal with this machine, but for whatever reason after all this time it just decided to be a problem. However, thankyou for the mesa-amber info.

1 Like

You could also try it as @jake99 said. I honestly couldn’t tell you it would be bettter or not. I think i see users still have the issue with flicker even using amber but it would need you to try both ways and do what works best for you on your hardware.

I would agree that modesetting is better than xf86-video-intel in almost any case, except on such old hardware. IIRC modesetting fully supports only Gen 4+ graphics with new mesa, it would be interesting to see how 2d/3d acceleration works on your system. But, hey, I am glad its working out for you anyway :smile:

1 Like

it would be interesting to see how 2d/3d acceleration works on your system

Anything I can try to help with that?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.