Only blinking cursor instead of login screen after GPU upgrade to RX 6600 XT

After I upgraded my GPU from a RDNA1 to RDNA2 RX 6600 XT, I get only a blinking cursor instead of the LighDM login screen. The GPU is showing the bootup text just as before, just not the login screen anymore. Since this GPU has been released only recently, I don’t necessarily expect many infos on it, especially on Linux and especially with those prices. I’ll test it tomorrow with a fresh new install again, since I bought a new M.2 NVME anyway (and current SATA drive will become additional backup). Maybe Linux >=5.14 is necessary, maybe mesa drivers not ready? Didn’t check the logs yet. I’ll also try Windows 10 if fresh install won’t work, just to see if Linux is the issue and make sure the GPU isn’t broken.

1 Like

https://www.phoronix.com/scan.php?page=article&item=radeon-rx6600xt-linux&num=2

I didn’t really want to mess with compiling again, but as it was required when I bought RDNA1 GPU a time ago, I did the same thing now as it was suggested on Reddit a few days ago, and I updated linux, linux-firmware (had already initial binary drivers but received recently update again), mesa and lib32-mesa to its latest -git version:

But before, make sure to edit /etc/makepkg.conf (or its local variant) and comment in the line MAKEFLAGS and edit it to MAKEFLAGS="-j$(nproc)" to utilize all CPU threads when compiling.

yay -S linux-firmware-git
Was done in like 10sec because no compilation required.

yay -S linux-git
Compilation took like 20-30min. One needs still to install manually using sudo pacman -U linux-git-headers-5.14rc5.r256.g0aa78d17099b-1-x86_64.pkg.tar.zst and updating the bootloader using sudo grub-mkconfig -o /boot/grub/grub.cfg.

yay -S mesa-git
Compilation took like 5min.

yay -S lib32-mesa-git
Compilation took like 5min.

Installing everything except linux-git didn’t work, so latest kernel-git compilation required.

Tested one OpenGL game and it works. Loading times are longer, not sure if shaders are being compiled at runtime, but we’ll see if loading times better over time.
The bigger problem now is that the Ethernet cable connection no longer works and when I switch back to linux 5.13.10, it works again (I check it over tty2 using ping).
Also, I had several times the mentioned blinking cursor again, despite using the latest linux-git now and another problem is that as soon as when I connect additional USB devices, like now, so I get any internet using USB WLAN adapter, the desktop freezes. I deattached one USB device so I can attach the USB-WLAN adapter and the desktop fortunately didn’t freeze, so at least Internet is working now. Maybe the blinking cursor problem was due to too many USB devices being attached, but this wasn’t a problem with my RDNA1 GPU and my B450 motherboard, but issues regarding B450 and USB devices are many according to forums posts everywhere, so I guess maybe I’m experiencing it too now. I guess maybe it has something to do with the number of PCIe lanes being utilized, as I’ve read in general about this some time ago, although this RX 6600 only uses 8 PCIe 4.0 lanes. Maybe a BIOS update is going to help. GPU has the 8pin power cable attached and power supply to GPU shouldn’t be the issue as the power supply is a 550 watts Corsair one.

edit:
BIOS update from latest stable to latest beta version unfortunately didn’t change anything on my B450 motherboard.
I ordered a B550 motherboard, let’s see if this helps. PCIe 3.0 of the B450 boards limits PCIe 4.0 GPUs in some cases, so it’s time to upgrade anyway (this would be not an issue if the GPU was PCIe 16x).

Although booting up with 1 more USB device attached doesn’t work, it works by first deattaching the USB device, booting up/logging in and attaching the USB device again, no desktop freezes anymore (I didn’t change anything).

Like 75% of the time the system does boot up with the mentioned blinking cursor and black screen only, even with linux-git (USB device not attached), and 100% of the time I get a blinking cursor and black screen only with official Arch’s linux 5.13.10, so compilation, as already mentioned, is definitely required.
If you don’t want to mess with compiling, wait for Arch’s official linux 5.14 and mesa 20.2 releases. I’m using mesa-git, but the soon to be arrived Arch’s official mesa 20.2 might also work.

System is stable once boot up.

The biggest problem is the not working 1gig Ethernet of the motherboard (a PCI-to-Ethernet card could be a workaround).

Can’t edit previous post so new reply:

I fixed the LAN interface of my B450:

$ lspci | grep -i 'ethernet'
22:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

So it’s being detected.

Next I found out that it requires the r8168 module, so I tried

$ sudo modprobe r8168

but that gave me:

modprobe: FATAL: Module r8168 not found in directory /lib/modules/5.14.0-rc6-1-git

and indeed, while 5.13.10-arch1-1 contained an extramodules folder, /lib/modules/5.14.0-rc6-1-git did not.

Doing sudo pacman -S r8168 didn’t help and pacman said that it’s already installed.

What worked was downloading https://github.com/mtorromeo/r8168/archive/refs/tags/8.049.02.tar.gz and running sudo ./autorun.sh. The LAN interface came up and started working immediately, no restart required (no modprobe blacklisting required either). The module has appeared under /lib/modules/5.14.0-rc6-1-git/kernel/drivers/net/ethernet/realtek/r8168.ko.xz now (no extramodules folder).
So, for whatever reason, compiling an AUR kernel did not autodetect/autoinclude/autobuild that module.