Odroid N2+ not booting after Update

Just rebooted my system after performing an update.
The system never proceeds to the display manager stops at the systemd init screen
Here is my boot log:
https://clbin.com/s6o2G
Pacman history (pahis | eos-sendlog):
https://clbin.com/2tEWE

The system is running well otherwise. I’m able to ssh onto it.
Let me know if you want any more info. Any help is appreciated

mesa.

i just run

" sudo pacman -U /var/cache/pacman/pkg/mesa-22.1.4-1-aarch64.pkg.tar.xz "

that temp fix it for me

2 Likes

I haven’t booted my Odroid N2 KDE device in about 4 or 5 days.
I will try to boot & update in a few minutes.

Pudge

 upgraded mesa (22.1.4-1 -> 22.1.5-1)
 upgraded xkeyboard-config (2.36-2 -> 2.36-3)
 upgraded appstream-glib (0.8.0-1 -> 0.8.1-1)

that updated for me … mesa 1st for me alway … 555555

1 Like

add mesa to pacman.conf ignore list then?

Yup, boot doesn’t complete after update. Downgrading mesa fixed it.

Let me answer for @Sjhim, “Your computer, your rules”. :laughing:

Pudge

2 Likes

The thing is if I update my computer, it will update mesa too. I don’t know of any other way to address this issue temporarily

Editing pacman.conf is the easiest, and that is what I did.

On the other hand, if one doesn’t edit pacman.conf every time mesa breaks the upate you know it still isn’t fixed and simply downgrade it again. Then when mesa is fixed, you will definitely know it has been fixed.

Either way works.

Pudge

2 Likes

This has me howling :rofl:

1 Like

Either use yay or paru to do your update or use --exclude

IMO, too easy to forget about something in ignorePkg

3 Likes

I get a warning every single time I run pacman/yay

warning: mesa: ignoring package upgrade (22.1.4-1 => 22.1.5-1)
1 Like

I just updated my RPi 4b aarch64 KDE install and the update was good.
I haven’t heard anything from the x86_64 users complaining.
I don’t know about Pinebook Pro?

So if the Odroid N2 is the only device affected by this, a fix may be a long time coming.

Pudge

1 Like

is there kernel update for Odroid ?

pinebook pro fine

1 Like

Apparently, there is, so I will build it soon and @Pudge will have it in the repos later

1 Like

on side note … @sradjoker you had PBP few day now … it should be Purple or blue @ very least now :blush:

i just play :pray: your system your rules :+1:

I haven’t dealt that much with downgrading packages, that is why I’m asking for suggestions for how to go about it.

i lost!!! i no say thing about your question . alway good ask question if no sure . think you miss understand my post .

Yeah, I think you misunderstood mine too :rofl:

ok… think this end now . glad you fix problem you had …

1 Like