Odd partitioning and inability to dual boot on a two drive setup

Hello all,

Recently I installed EndeavourOS and I messed up the partitions a bit when I first installed it, which I only noticed after booting into the system post install. I rebooted my PC, going back into the installation USB, and went to redo the installation from scratch, properly separating my partitions this time.

I did the usual, setting up my partitions, however this time during the installation, the USB drive disconnected momentarily causing the installation to stop, and I had to redo it once more. It was at this attempt that I noticed that I wasn’t given an option to mount the boot to /boot/efi - in fact, there was no /boot/ option at all, only /efi - and while I thought it was strange for a moment, I proceeded and finished the installation anyway.

The next time I booted up my PC, I noticed that I had “two” separate installations of EndeavourOS in the systemd boot menu, which I found rather weird, considering how I chose the option to wipe the contents of my HDD. I didn’t think much of it and continued on using my computer as usual. However, just earlier, I decided to check out what that other (or rather, previous) installation of EOS is, and it seemed like it wanted to boot just fine, but then it got stuck trying to load something (I forgot exactly what, it had an unlimited time span worth of attempts), so I force shut down my PC, and when I booted it back on, it skipped the boot menu completely, going into my current EOS installation.

I hope this isn’t any issue, since my computer boots and runs fine. Here I also have the results of running lsblk:

lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS
sda      8:0    0 931,5G  0 disk 
├─sda1   8:1    0  19,5G  0 part /
├─sda2   8:2    0  19,5G  0 part /usr
├─sda3   8:3    0  19,5G  0 part /var
├─sda4   8:4    0 872,3G  0 part /home
└─sda5   8:5    0   600M  0 part /efi
sdb      8:16   0 223,6G  0 disk 
├─sdb1   8:17   0    16M  0 part 
└─sdb2   8:18   0 223,6G  0 part 

Where sda is the current EOS, and sdb is a Windows 11 SSD (which I will get to in a moment). I know that I should have a /boot/ mount point, where /efi would sit (which was the case in the first installation of EOS), but if this current setup doesn’t change much, then I suppose no harm will be done. Additionally, /boot/ exists, and this is the only thing inside:

sudo ls /boot
intel-ucode.img

My only thought here if I am to move /efi back into /boot/, is to do it through a live bootable USB and go from there, though I’m unsure how without reinstalling my entire OS just to accommodate for that. On that note, I’m unsure how to get the boot menu to show up again, since I would like to be able to use Windows as well.

Now, as for Windows, I’m rather confused as to why I am no longer able to boot into it (after the first install of EOS). The OS is on the SSD, but I simply cannot boot into it. Here’s what happens when I run efibootmgr:

sudo efibootmgr 
BootCurrent: 0002
Timeout: 1 seconds
BootOrder: 0002,0007,0005,0006,0008,000A,0009,0004
Boot0002* Linux Boot Manager	HD(5,GPT,350e50d2-8c73-4970-ae10-5d7f892ae6e7,0x800,0x12c000)/\EFI\SYSTEMD\SYSTEMD-BOOTX64.EFI
Boot0004* Windows Boot Manager	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000000000100000010000000040000007fff0400
Boot0005* WDC WD10EZEX-00WN4A0	BBS(HD,,0x0)0000424f
Boot0006* KINGSTON SA400S37240G	BBS(HD,,0x0)0000424f
Boot0007* UEFI OS	HD(5,GPT,350e50d2-8c73-4970-ae10-5d7f892ae6e7,0x800,0x12c000)/\EFI\BOOT\BOOTX64.EFI0000424f
Boot0008* WD Elements 2621 1026	BBS(HD,,0x0)0000424f
Boot0009* UEFI: IS817 innostor, Partition 1	PciRoot(0x0)/Pci(0x14,0x0)/USB(8,0)/HD(1,GPT,66d5975c-cc3a-473e-aa85-0d5e2ff8a76a,0x800,0xefffd8)0000424f
Boot000A* IS817 innostor	BBS(HD,,0x0)0000424f

Note that I have no clue why it shows multiples of the same thing, but I dare not touch them lest I somehow brick my PC. Could the installation of EOS have wiped the Windows boot? If a simple reinstall of Windows will fix this, then it’s fine by me, I had no intention of keeping Windows 11 on my system any longer, I will go down to 10.

So, to sum it up, my /efi isn’t mounted to /boot/, but doesn’t seem to pose a problem, and installing EOS removed my ability to boot into Windows.

/boot/efi is used for grub and /efi is used for systemd-boot. If you were offered /boot/efi in a prior install, you probably selected grub that time.

Be aware that having a separate /var isn’t advisable on Arch-based distros because pacman stores some important data there. You can work with it but if you ever chroot into your install, be sure to also mount /var

No, we will never create a /boot mount point.

This looks normal to me.

0002 is EOS and 0004 is Windows.

Can we see sudo parted -l so we can get a few more details?

Here it is:

Model: ATA WDC WD10EZEX-00W (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name  Flags
 5      1049kB  630MB   629MB   fat32              boot, esp
 1      630MB   21,6GB  21,0GB  ext4
 2      21,6GB  42,6GB  21,0GB  ext4
 3      42,6GB  63,5GB  21,0GB  ext4
 4      63,5GB  1000GB  937GB   ext4


Model: ATA KINGSTON SA400S3 (scsi)
Disk /dev/sdb: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  17,8MB  16,8MB               Microsoft reserved partition  msftres, no_automount
 2      17,8MB  240GB   240GB   ntfs         Basic data partition          msftdata


Model: WD Elements 2621 (scsi)
Disk /dev/sdc: 2000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name      Flags
 1      1049kB  2000GB  2000GB  ntfs         Elements  msftdata

Is it possible that windows was using the EFI partition on the first disk?

I’m unsure. During the installation, I didn’t get an option to install alongside which would be common for other distros. I saw a comment on another post about a similar issue where Windows didn’t show up and was recommended for the /efi partition to be increased to at least 1GB, though seeing how they’re on separate drives I would be surprised if this had any effect on it.

Moreover, what is unexpected is that when I tried to boot into Windows through my BIOS, it would go to a black screen and put me back into the BIOS menu, which tells me that it might actually have had the EFI on the HDD rather than the SSD (where Windows is).

I used to have Pop!_OS installed on my HDD, and for some reason it kept the BIOS boot option which I deleted earlier, and it makes me think that it did indeed keep the EFI there rather than on the SSD. If this requires a complete reinstall of Windows, I’m fine with it as I said, I don’t plan to keep 11 on my drive.

I’m going to go ahead and reinstall Windows on the SSD and will post results later.