OBS NVFBC plugin not working with GTX 1050

Hello and sorry for disturbing anyone if this has been a recurrent topic in any way over here.
I’m currently running Endeavour with stock i3wm, using Xorg and a GTX 1050. I installed OBS right from the Arch community repos using yay, and then git cloned both the nvfbc patch and the .so file that the program needs to use the plugin.
I have put everything in its place, I have updated both my GPU drivers and the patch to version 510.60.02, I have pasted the plugin file to the ~/.config/obs-studio/plugins/nvfbc folder stuff, I launch OBS and all I get is a black screen. I thought it was just because the plugins folder doesn’t work but I have verified it does since I loaded the linux browser plugin and that does work.

Is there a dumb step I’m missing over here?? Have any of you guys encountered the same issue? Is there any sort of debugging output or something along those lines that I need to share?? I’ve only been troubleshooting this for a single day, so something must have escaped my mind. Sorry for the long post and thank you so much in advance.

What are these?

There may be some documentation for the NVFBC plugin, so that would be a good thing to look at.

1 Like

Is your GPU supported? I think not.

IMPORTANT: This plugin will NOT work with your regular NVIDIA GeForce

BTW, welcome aboard!


I’m having the same problem after upgrading from 510.54. Patching my drivers does make the NvFBC Source properties functional within OBS but the preview stays black. I think we might just have to wait for a fix to either the plugin or the patch, or downgrade to 510.54…

Edit: Nevermind downgrading. Tried it today and it didn’t seem to fix it. Maybe OBS got updated when I updated everything and the plugin is broken.

1 Like

Thank you for the greetings and reply! My GPU is not supported, however this is supposed to be remedied by the nvfbc patches that I said I cloned. If you’re curious about those, here is the github link: https://github.com/keylase/nvidia-patch

Tysm for the reply! Now that I think of it, you might be absolutely right, I’m pretty sure that the patches broke right after 510.54.
I’m guessing everything up to this point is now a matter of patience which is totally fine with me, I don’t need OBS urgently for now. Let’s see what’ll happen eventually

Those are GPU driver patches for the NVFBC plugin that became really popular for quite some time now, they’re used to make the whole Nvidia acceleration stuff cooperate nicely with modern Geforce GPUs. From what I’ve been reading recently, it appears my issue has come down to an update breaking things from both the driver and the patches’ side, so I believe everything now is just a matter of waiting to see a fix for those. If you’re curious about those, I’ve left the github link for them in another reply of mine under this issue.

I don’t know exactly if this can be closed for now, but it appears the issue isn’t the plugin, so mystery solved. Thank you once again for the reply!

Just coming by to say updating to NVIDIA 510.68.02 and patching fixed it for me. :slight_smile: