(NVM, made new thread) Interface is broken after updating / reinstalling

After I updated, and reboot, I get the situation you can see in the photo I uploaded in my initial thread. Low resolution, no interface, just a welcome popup and my only option to interact with the system is CTRL+ALT+T and try and figure out everything via the CLI.

I re-installed using the latest KDE Endeavour OS, and I get exactly the same issue! So there was no need to re-install… I still have to solve this problem.

@pebcak told me to log out, but actually I see no way to log out. I found this command while searching
loginctl terminate-session 1
that just sent me to a black screen with a flashing cursor… unresponsive.

Are you using autologin? If so, did you edit the file to change your default session to X11?

I don’t know what any of that means, sorry. All I did in the first place was let the auto updater run, encountered this situation - re-installed from the latest Endeavour OS KDE image, and encountered the same situation again.

did you set up your system to go from boot to Desktop bypassing the need for username/password

What auto updater?

Sorry, I didn’t realise there was more than one way - I’m just using everything straight down the line as possible. The buttons on the welcome menu, there’s 2, one refers specifically to EOS I believe. I recall when the CLI pops up after you press one of them, it seems all it does is run “yay” so I took to just typing that myself sometimes, and letting it run its course.

Ah yes - when I am running the installer, that is one of the options I choose when it’s presented, I just like the computer to boot straight into the desktop.

you need to edit the session. It sounds like the update has you in Wayland(Known Behavior) This was done via the latest update to KDE Plasma 6. Prior the default was X11. Hopefully someone can tell you the file you need to edit if you don’t know as I’m assuming something with sddm however I don’t use either KDE or sddm nor do i ever recommend autologin but your computer your rules.

Hey if it means there’s less chance I lose time to problems like this, I will not chose the option. I just had no idea skipping login would have any other impact other than allow any one to use my computer, which I didn’t see the point of having since I’m the only one who uses it.

I will even re-install Endeavour OS with some other recommended desktop manager if that will fix this? I only have ever stuck with KDE because it seemed to have the best support for my Wacom tablet from all the others I tried.

I noticed in the previous version of Endeaver OS I would use for the live boot, it was some other desktop environment that I can’t remember the name of. I used it on a cheap laptop I set up - and I noticed it did something frustrating with multimonitor setups - I believe it always set the leftmost monitor to be the primary monitor (the one with the taskbar), regardless of which one you set to “primary” in the display settings interface, so if you have a smaller monitor to the left of your primary monitor, this screws you up. I did a quick look around and it looked like a known issue that I saw someone said they wrote a script to work around. It would be good to avoid the desktop environment that has this issue if possible, since my main PC has 3 monitors, the primary one being in the middle of course.

Look into the file /etc/sddm.conf.

Under [Autologin] set Session=plasmax11

This should log you automatically into X11 session instead of Wayland.

See if still experience theses “glitches”.

1 Like

I will do that next - also, after thinking about what @thefrog said, I guess I could also try re-installing, but without the auto login option, that might also open up some options.

Without autologin, upon booting up your system, you will get to the login screen.

In the bottom left of the screen, you could choose which seesion you want to log into Wayland (default now after KDE Plasma 6) or X11.

I don’t have a Plasma install to try and give you the exact method of disabling autologin but here is a couple of things you could try:

  1. In the system settings go to Start up an Shutdown. Then to Login Screen. Under Behaviour … button, uncheck automatic login. Not sure if this is all to be found in Plasma 6 at the same place or not but just for you to know what to look for.


  1. In the file mentioned above, comment out the two line User and Session by putting # before them.

I’m back (after 74 days according to the topic revive warning) I’ve put some time into trying to fix this.

I was not able to follow the instructions in your last post since EndeavourOS was no longer booting.

I re-installed EndeavourOS using the new Gemini image, I checked Auto Login again by mistake, ended up with the same problem as above, checked the forum, realised my mistake, figured it was easier to just re-install…

Re-installed again, but randomly, the install failed at the very end saying it couldn’t modify the boot loader. It offered to “paste the log to the web” and provided this link https://termbin.com/t05v

I rebooted, and after choosing the latest EndeavorOS entry in the boot menu, the booting never finishes, looks like it can’t find the partition.

All I need to do is edit the loader on the EFI partition apparently, sounds simple, right? I want to remove all those dead entries anyway.

Thing is, I’m in live boot, so (if I understand correctly) the EFI partition currently in use is different than the one I need to edit. Edit: Actually I’ve just realised maybe efibootmgr can do this, just going to look at how…

I figured I’d just try re-installing (I am choosing “replace a partition” option every time) - it failed at the end with another error “Bad script” from what I remember, it sounds again like it had trouble updating the boot menu.

2024-05-30 - 13:30:34 [1]:     ERROR: Installation failed: "Bad main script file" 
2024-05-30 - 13:30:34 [6]:     .. - message: "Bad main script file" 
2024-05-30 - 13:30:34 [6]:     .. - details: Main script file /usr/lib/calamares/modules/bootloader/main.py for python job bootloader raised an exception.

It always is able to find the EFI partition at /dev/nvme0n1p5, and I can still boot into Windows from it. Just no idea why subsequent installs are failing in this way. I will go back to trying to manually edit the loader…

When I run efibootmgr, this output - is it finding different boot loaders, or is it the actual list of boot options?

[liveuser@eos-2024.04.20 ~]$ sudo efibootmgr
BootCurrent: 0009
Timeout: 1 seconds
BootOrder: 0003,0000,0009,000A,0001,0002,0006,0007,000B
Boot0000* Windows Boot Manager  HD(1,GPT,cec35240-5c10-4cb5-899b-50ebc6170f5f,0x800,0x32000)/\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000049000100000010000000040000007fff0400
Boot0001* ST2000DL003-9VT166    BBS(HD,,0x0)0000424f
Boot0002* ST3000DM007-1WY10G    BBS(HD,,0x0)0000424f
Boot0003* Linux Boot Manager    HD(5,GPT,c2c15111-5138-4d18-9e31-29bf8caa1e9d,0x9c91790,0x1f4000)/\EFI\SYSTEMD\SYSTEMD-BOOTX64.EFI
Boot0006* Samsung SSD 970 EVO 500GB     BBS(HD,,0x0)0000424f
Boot0007* ST4000VN008-2DR166    BBS(HD,,0x0)0000424f
Boot0009* UEFI: KingstonDataTraveler G3 1.00, Partition 1       PciRoot(0x0)/Pci(0x14,0x0)/USB(1,0)/HD(1,MBR,0x7498467c,0x501b60,0x4f800)0000424f
Boot000A* UEFI: KingstonDataTraveler G3 1.00    PciRoot(0x0)/Pci(0x14,0x0)/USB(1,0)/CDROM(1,0x501b60,0x13ea6)0000424f
Boot000B* KingstonDataTraveler G3 1.00  BBS(HD,,0x0)0000424f

I suspect it may be showing the different boot loaders - I have a windows one at the start of the drive, from a fresh install of windows on an empty disk - then I have a 2nd Linux loader after that, from installing EndeavourOS with the “install alongside” option and I believe this is the current boot loader. And then because I’m currently in a live boot, it’s showing the bootloader from the USB drive “KingstonDataTraveller”

How do I edit the Linux one specifically? The instructions I find seem to be running from the booted system, but I can’t boot into mine, I need to edit the boot menu from a live boot.